[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #56900] Octave hang in "linux on dex" on samsu

From: anonymous
Subject: [Octave-bug-tracker] [bug #56900] Octave hang in "linux on dex" on samsung tablet
Date: Sun, 15 Sep 2019 20:14:16 -0400 (EDT)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux aarch64; rv:69.0) Gecko/20100101 Firefox/69.0


                 Summary: Octave hang in "linux on dex" on samsung tablet
                 Project: GNU Octave
            Submitted by: None
            Submitted on: Mon 16 Sep 2019 12:14:15 AM UTC
                Category: Configuration and Build System
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: Unexpected Error
                  Status: None
             Assigned to: None
         Originator Name: eric m
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 5.1.0
        Operating System: GNU/Linux



I have successfully compiled Octave 5.1.0 on "Linux on Dex" (LoD), the linux
environment available on android on some samsung phones and tablets. I have
the tab s5e. So the build is for arm processor.

So far there are two issues. Before I get into those... the gui starts up just
fine, and octave also starts just fine. The editor works, etc. All seems well.
But then...
1. I can do simple things like add 1+1, so octave is up and running. I can
input a matrix and take its transpose. However if I try to invert the matrix,
octave hangs. So I recompiled with different BLAS and LAPACK libraries
available (openblas, blas, etc.) but no matter which blas and lapack libraries
I link to it still hangs. 

2. Graphics. I tried both qt, and gnuplot for plotting, but it fails to
produce a plot when compiling with or without opengl. I don't even know if
this is where I should be looking for that issue. This produces the same kind
of hang.

Both hangs go to "defunct" when looking at "ps aux | grep octave". 

I tried looking at the output of strace, but I didn't see anything that stuck
out. Perhaps someone else might have some ideas. Anything else I should try or
log files I should send?

Here is my configure command:
  $ ../configure --prefix=/home/dextop/packages/SOURCE/octave-5.1.0/ehm_build
--with-lapack=/usr/lib/liblapack.so --with-blas=/usr/lib/libblas.so

Thanks for any info!


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]