[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #57095] curl not found when installed from Ubu

From: anonymous
Subject: [Octave-bug-tracker] [bug #57095] curl not found when installed from Ubuntu snap
Date: Mon, 21 Oct 2019 15:12:43 -0400 (EDT)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0


                 Summary: curl not found when installed from Ubuntu snap
                 Project: GNU Octave
            Submitted by: None
            Submitted on: Mon 21 Oct 2019 07:12:41 PM UTC
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: Unexpected Error
                  Status: None
             Assigned to: None
         Originator Name: David
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 5.1.0
        Operating System: GNU/Linux



Ubuntu 18.04


sudo snap install octave

octave --eval "system('curl -V')"

The above results in a curl not found error.

curl works as expected if run from a terminal. When running the above command
with strace, I see snap-confine in the output and suspect Octave is sand-boxed
and can't run curl.

I tried running octave with sudo. I also tried reinstalling with --classic and
--devmode snap flags but same result.


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]