[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #57584] spurious test "FAIL"s when running tes

From: Hartmut
Subject: [Octave-bug-tracker] [bug #57584] spurious test "FAIL"s when running test suite in Octave with "--traditional" startup parameter
Date: Sun, 12 Jan 2020 15:24:24 -0500 (EST)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:72.0) Gecko/20100101 Firefox/72.0


                 Summary: spurious test "FAIL"s when running test suite in
Octave with "--traditional" startup parameter
                 Project: GNU Octave
            Submitted by: hardy
            Submitted on: Sun 12 Jan 2020 08:24:22 PM UTC
                Category: Test Suite
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: None
                  Status: None
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: dev
        Operating System: Any



I have observed this with a self compiled current dev Octave under linux. I
don't think it's a big problem, but will report it here anyways.

Here is how to reproduce it:
* start Octave (gui or cli) with the startup option "--traditional"
* run the full test suit via run_test_suite (wait a bit...)
* at the end it reports many FAILs of tests, 91 FAILS in my case.
* search the text output of run_test_suite inside the console to pick one
function with a FAIL, e.g. hgsave.m or copyobj.m.
* manually run the tests of this function, e.g. "test hgsave.m" to see that
there are actualla NO test failures.
* have a look in fntests.log. There are also NO real test failures noted.

My conclusion is that the "problem" is somewhere in the routine of
run_test_suite itself, since all tests I run manually eventually passed.

I don't know if this is a "legal" use case of run_test_suite at all. But it
makes it hard to evaluate if some real tests fail when using this startup
option. (I wanted to check this, because of the now solved bug #57528.)


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]