[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #62681] pkg test: Tests outside of the specifi

From: Markus Mützel
Subject: [Octave-bug-tracker] [bug #62681] pkg test: Tests outside of the specified package are being run
Date: Wed, 6 Jul 2022 06:12:46 -0400 (EDT)

Follow-up Comment #10, bug #62681 (project octave):

Thank you for the instructions.
But to be honest, I'm a bit at a loss when it comes to running those docker
I installed docker on Ubuntu 22.04 with `sudo apt-get install docker.io`.
After that, I tried to pull Octave with the first command from comment #9.
That didn't work unless I ran it with `sudo`.

It also looks like I need to start docker with `sudo` with whatever command I
tried after that. Without `sudo`, it would always fail with something along
these lines:

$ docker run -it --rm gnuoctave/octave:7.1.0 octave-cli --eval "geteuid ()"
docker: Got permission denied while trying to connect to the Docker daemon
socket at unix:///var/run/docker.sock: Post
"http://%2Fvar%2Frun%2Fdocker.sock/v1.24/containers/create": dial unix
/var/run/docker.sock: connect: permission denied.
See 'docker run --help'.

I tested the following:

$ sudo docker run -it --rm gnuoctave/octave:7.1.0 octave-cli --eval "geteuid
Entered start.sh with args: octave-cli --eval geteuid ()
Executing the command: octave-cli --eval geteuid ()
ans = 1111
error: ignoring const execution_exception& while preparing to exit

But as you can see, that doesn't return `0` for me. So, I'll probably not be
able to reproduce the original issue with this anyway...

I also suspect that the "docker Octave" didn't run as root in comment #9
either. So, the package would be installed at a different location. And the
folders in those commands won't be created.

Is there a way how I could replicate the situation for the original issue?
(I.e., a "docker Octave" that will report that it runs as root.)


Reply to this item at:


Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]