octave-maintainers
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Package system


From: Paul Kienzle
Subject: Re: Package system
Date: Sat, 22 Oct 2005 15:04:13 -0400


On Oct 21, 2005, at 1:18 PM, John W. Eaton wrote:

  * The remaining functions currently have the following names

      installed_packages.m
      load_packages.m
      uninstall.m
      get_unsatisfied_deps.m
      install.m

    Maybe we should have just one command?

      pkg -list
      pkg -install -nodeps pkg-name ...
      pkg -uninstall nodeps pkg-name ...
      pkg -require pkg-name ...

    or multiple names, but all starting with pkg:

      pkg_list
      pkg_install
      pkg_uninstall
      pkg_require (or pkg_load)


Maintaining my debian system became a lot more pleasant once I started using wajig. Using a single prefix for all commands is a very good thing.

Give that the pkg command is never called without a '-subcommand' I would argue for pkg_subcommand. Later when we have syntactic support for namespaces then we can break it into pkg.subcommand (assuming a namespace is a first class object like in python) or pkg::subcommand (assuming a namespace is something syntactic like in C++).

At a minimum, use the syntax "pkg subcommand" rather than "pkg -subcommand" since the subcommand is a requirement rather than an option.

- Paul



reply via email to

[Prev in Thread] Current Thread [Next in Thread]