[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.9.8 Build problems on Opteron (RHEL4)

From: Fredrik Lingvall
Subject: Re: 2.9.8 Build problems on Opteron (RHEL4)
Date: Wed, 06 Sep 2006 11:48:27 +0200
User-agent: Thunderbird (X11/20060802)

frank wang wrote:
When I compiled octave with umfsparse, I got the same error message complaining the mistype in log2 of proto.h. What I did is comment out the code in proto.h and successfully made the octave.

This worked for me too. Thanks!
On 9/5/06, John W. Eaton <address@hidden> wrote:
On  5-Sep-2006, Fredrik Lingvall wrote:

| * With the umfpack stuff I get this error (using gcc 4.1.1 ):
| F77=gfortran CPPFLAGS="-I$HOME/work/OPTERON/usr/local/include"
| CFLAGS="-O3 -m64 -Wall -funroll-loops -march=opteron -mtune=opteron
| -pthread" CXXFLAGS="-I$HOME/work/OPTERON/usr/local/include -O3 -m64
| -Wall -funroll-loops -march=opteron -mtune=opteron -pthread"
| FFLAGS="-I$HOME/work/OPTERON/usr/local/include -O3 -m64 -Wall
| -funroll-loops -march=opteron -mtune=opteron -pthread"
| LDFLAGS="-L$HOME/work/OPTERON/usr/local/lib" ./configure  --enable-64
| --prefix=$HOME/work/OPTERON/usr/local
| --with-blas=$HOME/work/OPTERON/usr/local/lib/libBLAS.so
| --with-lapack=$HOME/work/OPTERON/usr/local/lib/libLAPACK.so

Are you sure you want --enable-64?  Did you note the warning issued by
configure when you use it?
Yes and yes. I used gfortran from gcc 4.1.1 and Goto BLAS v 1.04 so I hope its OK. At
least I do not get any core dumps or other errors.

BTW, instead of

F77="..." CFLAGS="..." ...  configure --other-options ...

it is generally best to use

configure F77="..." CFLAGS="..." ... --other-options ...

because then the values of these variables are recorded in the
config.status file.
Ah, thanks. Will do that from now on.

This looks like a bug in something other than Octave.  What package does
the file


belong to?
I think it is from METIS.

Please try the following patch and let me know if it allows you to get
past this problem.


Yes the patch made 2.9.8 compile nicely. Seems to run fine too. Thanks!
I did not get these errors on my 32-bit Gentoo laptop.  Do you know why
it failed on the 64-bit machine?



2006-09-05  John W. Eaton  <address@hidden>

       * mex.cc (mxArray_sparse::as_octave_value): Cast nzmax to
       octave_idx_type for sparse matrix constructors.

Index: src/mex.cc
RCS file: /cvs/octave/src/mex.cc,v
retrieving revision 1.8
diff -u -u -r1.8 mex.cc
--- src/mex.cc  27 Jul 2006 03:21:03 -0000       1.8
+++ src/mex.cc  5 Sep 2006 20:11:01 -0000
@@ -1392,7 +1392,8 @@
         bool *ppr = static_cast<bool *> (pr);

-         SparseBoolMatrix val (get_m (), get_n (), nzmax);
+         SparseBoolMatrix val (get_m (), get_n (),
+                               static_cast<octave_idx_type> (nzmax));

         for (int i = 0; i < nzmax; i++)
@@ -1418,7 +1419,8 @@
             double *ppr = static_cast<double *> (pr);
             double *ppi = static_cast<double *> (pi);

-             SparseComplexMatrix val (get_m (), get_n (), nzmax);
+             SparseComplexMatrix val (get_m (), get_n (),
+                                      static_cast<octave_idx_type> (nzmax));

             for (int i = 0; i < nzmax; i++)
@@ -1435,7 +1437,8 @@
             double *ppr = static_cast<double *> (pr);

-             SparseMatrix val (get_m (), get_n (), nzmax);
+             SparseMatrix val (get_m (), get_n (),
+                               static_cast<octave_idx_type> (nzmax));

             for (int i = 0; i < nzmax; i++)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]