[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: FW: error: load: ../some image directory/..: inconsistent number of

From: Quentin Spencer
Subject: Re: FW: error: load: ../some image directory/..: inconsistent number of colum
Date: Wed, 06 Sep 2006 14:08:00 -0500
User-agent: Thunderbird (X11/20060808)

Joe Koski wrote:
------ Forwarded Message
From: "John W. Eaton" <address@hidden>
Date: Tue, 5 Sep 2006 21:42:24 -0400
To: Joe Koski <address@hidden>
Cc: shoker_17 <address@hidden>, <address@hidden>
Subject: Re: error: load: ../some image directory/..: inconsistent number of

On  5-Sep-2006, Joe Koski wrote:

| Having said that, I have been seeing the same problem with octave-2.9.8 on
| my Mac. I havenĀ¹t asked about the problem because octave-2.9.x is still
| under development, and it may just be a matter of time until the problem
| corrected.

Maybe you should report the problem, along with enough information to
allow someone to debug it.  It's hard to fix problems when they
haven't been reported.


------ End of Forwarded Message

OK, I hear you, but just playing around, I can't get octave-2.9.8 to read
any image on my machine, regardless of whether they are .jpg, .tiff, etc. I
have tried both imread and loadimage, and neither seems to be working as
they have in the past. The test is simple - just try opening any .jpg file.

For imread, I get

octave:1> A=imread("Full-fire-later-bw.jpg");
error: `IMAGEPATH' undefined near line 41 column 23
error: evaluating argument list element number 1
error: evaluating assignment expression near line 41, column 8
error: called from `imread' in file
error: evaluating assignment expression near line 1, column 2

How do I define IMAGEPATH for octave-forge?

This is fixed in CVS (and discussed a month or so ago on one of the lists). The problem is that IMAGEPATH is now IMAGE_PATH. If you add that one character in your imread function, it will work.

For loadimage, I get

octave:2> A=loadimage("Full-fire-later-bw.jpg");
error: load: /Users/jakoski/Codes/octave_test_files/Full-fire-later-bw.jpg:
inconsistent number of columns near line 2
error: load: unable to extract matrix size from file
error: called from `loadimage' in file
error: evaluating assignment expression near line 2, column 2

Which is the error that shoker_17 is reporting. I have read that same image
before with octave-2.1.73.

With imread or loadimage? As far as I know, loadimage has always been for octave's image format, and imread for all of the others. I would expect imread would work correctly with 2.1.73.

Is there an image reading test that is part of octave or octave-forge? Since
every part of octave-2.9.8 that I really need is working, I had assumed that
image reading was a work in progress, and would eventually get fixed. I want
to help, but for me to stand around saying that things just don't work is
not useful to anyone, especially when people are already aware of the
problems. I'm not sure which part of image reading falls onto octave turf
(loadimage?), and which is part of octave-forge (imread?), and why they both
exist (history?).

To check things correctly, I should probably be working with the latest CVS
octave-forge. When I attempt to use the CVS instructions on the octave
repository web page, I get:

Joe-Koskis-Computer:~ jakoski$ cvs
-d:pserver:address@hidden:/cvsroot/octave login
Logging in to :pserver:address@hidden:2401/cvsroot/octave CVS password: cvs login: CVSROOT may only specify a positive, non-zero, integer port (not
cvs login: Perhaps you entered a relative pathname?
cvs login: warning: skipping invalid entry in password file at line 1

Do I need to export CVSROOT=something before I attempt login?

I wouldn't think so. I just tried an anonymous checkout using the command you used above and did not get the error messages. I wonder if this is something Mac-specific?

Once I get past that, I assume the modulename that I want is octave-forge.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]