[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Second attampt at new octave-forge web site

From: Joe Koski
Subject: Re: Second attampt at new octave-forge web site
Date: Tue, 17 Oct 2006 10:13:43 -0600
User-agent: Microsoft-Entourage/

on 10/17/06 2:02 AM, David Bateman at address@hidden wrote:

> Joe Koski wrote:
>> on 10/16/06 2:05 PM, David Bateman at address@hidden wrote:
>>> Dear All,
>>> Soren and I have been working to address the remaining issues on the
>>> octave-forge website and the issues raised from our previous test site.
>>> Please check http://octave.dbateman.org
>>> The changes we made include
>>> * The most noticeable change is that we changed the site from green to
>>> blue, to make a clear distinction between the octave and octave-forge
>>> sites. We also changed the sombrero logo to green. Neither Soren or I
>>> are web designers, so any other thoughts would be appreciated on how to
>>> address this request from John.
>>> * The front-page now has a "Recent News" heading. There is also a News
>>> Archive that replaces the RELEASE-NOTES from the monolithic octave-forge.
>>> * The package page now uses javascript to hide the description, till the
>>> package title is clicked. This allows a much denser list of packages
>>> * All of the webpages have been passed through http;//validator.w3.org
>>> and the CSS file through http://jigsaw.w3.org/css-validator/. There is
>>> one remaining errors of the "text-align:" in the div#sf_logo section. If
>>> you know a fix please tell?
>>> * The categories index has been made consistent, and alphabetically sorted
>>> * The package function references now contain only the functions in the
>>> package itself listed alphabetically. The full categories index is still
>>> available from the documentation page. This makes a clear distinction
>>> between code in one package or another and those functions in octave itself
>>> * The tar-balls of the packages have the same sub-directory name as the
>>> package itself.
>>> The problems that we know remain and don't propose to fix before a
>>> release are
>>> * The GPC and graceplot packages have not been converted to the package
>>> manager
>>> * The CSS file has the one remaining error discussed above
>>> * We really should move www/ to doc/htdocs to simplify the octave-forge
>>> source tree and make the install on the website easier.
>>> Can you please suggest any further changes that you'd like to this site.
>>> If there are no further comments, Soren and I propose to take the site
>>> live later this week.
>>> Regards
>>> David
>> David,
>> First, let me say that I think that you and Soren are headed in the right
>> direction with octave-forge. I think the new package scheme, once worked
>> out, will be better for both users and maintainers.
>> My initial comments here are in my role as the perfect analog for the
>> average "dumber-than-snot" Mac user.
>> For the record, this is with OS X 10.4.8, Xcode-2.4 developer tools, and
>> octave-2.9.9 built with g95 on a G5 PowerPC Mac. This is the latest OS, but
>> not the latest Intel machine.
>> The first thing that I noticed was that Mac OS X has a habit of un-gzipping
>> any downloaded file into a just plain .tar file. Yes, I could find the
>> correct box to check or uncheck in the Finder preferences, but the average
>> Mac user doesn't usually go there. Should pkg be smart enough to look at the
>> extension? I know that .tar.gz has other alternates such as .tgz. Excuse me
>> if you have already thought about all of this.
>> As an initial test, I downloaded image-1.0.0.tar.gz from your test site,
>> and, as I said, this immediately became image-1.0.0.tar. I moved the .tar
>> file into a folder called /Downloads_and_Updates/octave-forge_packages and
>> tried
>>   pkg install image-1.0.0.tar
>> but I got an error, so I gzipped it back into a .tar.gz and tried
>>   pkg install image-1.0.0.tar.gz
>> and I got pretty much the same errors:
>> GNU Octave, version 2.9.9 (powerpc-apple-darwin8.8.0).
>> Copyright (C) 2006 John W. Eaton.
>> <snip>
>> octave:1> pkg install image-1.0.0.tar.gz
>> warning: You have not defined an installation prefix, so the following will
>> be used: /Users/jakoski/octave/
>> tar: image-1.0.0.tar.gz: Cannot open: No such file or directory
>> tar: Error is not recoverable: exiting now
>> warning: implicit conversion from scalar to string
>> error: tar: tar exited with status =
>> Octave was started in the same working directory as image-1.0.0.tar.gz.
>> Then I tried help pkg, and noticed that it's not complete yet. How to fix
>> this should probably be referenced somewhere in the final help package. I
>> have no problem with the default location for the package of ~/octave.
>> My first guess is that octave is having trouble with the Apple tar, but I
>> can't confirm that. The irony is that on my old Mac, I had to type man
>> gnutar to get the man file for tar, although tar -xvf etc. works just fine.
>> On the new Mac OS, man tar works just fine, as does tar.
>> One other issue. On Macs, to install files into /usr/local (which doesn't
>> exist until the Mac user creates it), you must, typically, "sudo make
>> install" and then enter your "administrator" password. Should there be a
>> provision for installing into protected areas, or should that be left for
>> only the more experienced users? Yes, you could also, like any *IX, log in
>> as root and do the installation.
>> As always, I can try things to see if they work. Let me know what to try
>> next.
>> Joe
> Joe,
> I suspect this might be fixed in the CVS. Could you take the pkg
> function from
> http://velveeta.che.wisc.edu/cgi-bin/cvsweb.cgi/~checkout~/octave/scripts/pkg/
> pkg.m?rev=1.21;content-type=text%2Fplain
> and use it instead to see if it helps? You'll also need
> http://velveeta.che.wisc.edu/cgi-bin/cvsweb.cgi/~checkout~/octave/scripts/misc
> ellaneous/compare_versions.m?rev=1.1;content-type=text%2Fplain
> Regards
> David


Some progress. I got the CVS files that you suggested, and placed them in
the folder with the tar.gz.

When I tried the run, I got:

octave:1> ls
compare_versions.m      image-1.0.0.tar.gz      pkg.m
octave:2> pkg install image-1.0.0.tar.gz
tar: image-1.0.0.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
warning: implicit conversion from scalar to string
error: tar: tar exited with status =
octave:2> which tar
tar is the user-defined function from the file
octave:3> exit

Then I tried:

jakoski$ tar -xvzf image-1.0.0.tar.gz -C ~/octave/

and the .tar.gz unpacked correctly into /octave in my home directory, but,
obviously, did not run Makefile to build the .oct files.

Should I be poking around in tar.m looking for the reason? Do I need the CVS


reply via email to

[Prev in Thread] Current Thread [Next in Thread]