[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Pkg-octave-devel] Bug#394982: octave2.9: Crashes on "x(:, :)=speye(

From: Quentin Spencer
Subject: Re: [Pkg-octave-devel] Bug#394982: octave2.9: Crashes on "x(:, :)=speye(1)"
Date: Tue, 24 Oct 2006 08:31:16 -0500
User-agent: Thunderbird (X11/20060913)

Rafael Laboissiere wrote:
* David Bateman <address@hidden> [2006-10-24 14:18]:

Thomas Weber wrote:
Am Dienstag, den 24.10.2006, 12:55 +0200 schrieb Rafael Laboissiere:
address@hidden:~/orion/trunk/solver$ octave -q
octave:1> x(:,:)=speye(1);
panic: Segmentation fault -- stopping myself...
Segmentation fault
I tried this with CVS and it crashes as well:

octave-2.9.9+:1> x(:,:)=speye(1);
*** glibc detected *** free(): invalid next size (fast): 0x0000000001611150 ***
panic: Aborted -- stopping myself...
attempting to save variables to `octave-core'...
save to `octave-core' complete


I just tried this with a CVS from Sunday on an Mandriva 2006 system and could not generate that same error..

This works in my Debian etch system with octave2.9-2.9.9-3::

    octave2.9:1> speye (1);
    octave2.9:2> x = speye (1);

But this don't:

    octave2.9:1> x (:, :) = speye (1);
    panic: Segmentation fault -- stopping myself...
    *** glibc detected *** malloc(): memory corruption (fast): 0x0904d970 ***
    panic: attempted clean up apparently failed -- aborting...

There is something weird with the indexing operation on the lefthand side
when the variable being assigned is undefined.  For instance, this works:

    octave2.9:1> x = speye (1);
    octave2.9:2> x (:, :) = speye (1);

At any rate, the malloc problem reported in the error message may indicate
some Debian-specific bug.

It crashes octave-2.9.9-1.fc5 on Fedora as well, with the same error messages.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]