[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MSVC/Win32: building the documentation

From: John W. Eaton
Subject: Re: MSVC/Win32: building the documentation
Date: Sun, 29 Oct 2006 18:49:46 -0500

On 29-Oct-2006, Michael Goffioul wrote:

| John W. Eaton a écrit :
| > OK, this problem was bugging me, and I found a few minutes.  Does the
| > following patch help?
| >   
| Yes it does. Thanks.
| However, I have something to ask. I tried to compile octave with MSVC 
| from the cygwin
| shell instead of MSYS (packages are more up-to-date and easier to 
| install). Everything went
| almost fine except for 2 things, maybe you can help.
| 1) the current gperf version provided by cygwin is 2.7.x. This version 
| produces an invalid
| header (the result type of octave_kw_hash::in_word_set is empty). Is it 
| possible to use this
| version, or do I really need an more recent version (which is 
| unfortunately not available
| by default)

See the bug reported today about this.  I think it would be best to
just install a newer version of gperf, or, since the generated file is
not system dependent, you can copy the generated file from another

| 2) building the doc fails at various points:
|     - when generating the figures with run-octave, it looks like the 
| process is terminated
|       before the actual file has been written by gnuplot, resulting in 
| an empty file; I solved
|       that by adding a "sleep(1)" command after the regular command of 
| run-octave in
|       doc/interpreter/Makefile.in

There is already a sleep (1) in the sparseimages.m file, but it might
not be in the right place if you don't have the sparse libraries.
Anyway, since we might someday have other images, I think it makes
more sense to put the sleep where you did.  I made the change.

|     - texi2dvi gives an error I can't decode:
| This is e-TeXk, Version 3.141592-2.2 (Web2C 7.5.4)
|  file:line:error style messages enabled.
|  %&-line parsing enabled.
| ---! /var/lib/texmf/web2c/etex.fmt was written by pdfetex
| (Fatal format file error; I'm stymied)
| /usr/bin/texi2dvi: texinfo.tex appears to be broken, quitting.
|       If I manually set TEX=tex before calling texi2dvi, it works fine. 
| Do you have any
|       idea about what's going on?

Is e-TeXk from a Cygwin package?  Is your Cygwin installation up to
date?  I think this is either an installation problem on your system,
or a bug in the packaging.  If a little googling doesn't turn up a
solution, then ask for help on the Cygwin list.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]