[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cross-building with --enable-64: Assembly error

From: John W. Eaton
Subject: Re: cross-building with --enable-64: Assembly error
Date: Fri, 15 Aug 2014 17:23:38 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Icedove/24.5.0

On 08/15/2014 12:59 PM, John D wrote:
Message: 2
Date: Thu, 14 Aug 2014 14:21:21 -0700 (PDT)
From: PhilipNienhuis <address@hidden>
To: address@hidden
Subject: MXE: cross-building with --enable-64: Assembly error
Message-ID: <address@hidden>
Content-Type: text/plain; charset=us-ascii

Tried to cross-build Octave for Windows with --enable-64, but got this when
builing libgcrypt:

libtool: compile:  x86_64-w64-mingw32-gcc -DHAVE_CONFIG_H -I. -I.. -I../src
-g -O2 -Wall -MT rndhw.lo -MD -MP -MF .deps/rndhw.Tpo -c rndhw.c
-DDLL_EXPORT -DPIC -o .libs/rndhw.o
/tmp/ccDbQOKt.s: Assembler messages:
/tmp/ccDbQOKt.s:53: Error: unsupported instruction `mov'
make[4]: *** [rndhw.lo] Error 1
make[4]: Leaving directory

Is this due to too aggressive optimization? "mov" looks like one of the most
basic CPU instructions to me....

My system: Mageia 2 32-bits (2 years old).



Not that it helps any, but it compiles fine on my Fedora 20 box .

According to the log, the -O2 optimization is used on mine.

A quick look on the internet shows a few other people have had similar
issues when building gcrrypt.

You used --enable-64 and the GCC 4.9.0 cross compiler that is built by mxe-octave?

I tried a fresh build with --enable-64 on a 64-bit Debian system and it failed with the same assembler error message that Philip reported.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]