[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to install 4.0 with Ubuntu

From: Curt Carpenter
Subject: Re: Unable to install 4.0 with Ubuntu
Date: Thu, 11 Jun 2015 20:14:33 -0500
User-agent: Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Thunderbird/31.7.0

Thank you both for your assistance.  Octave 4.0 successfully installed with GUI on this try.

For future Octave users like that may want to install Octave 4.0 under Ubuntu 14, here is a
summary of what worked for me:

    o  Download Octave 4.0 and extract it into a directory of your choice.

    o  Remove any installed versions of Octave on your Ubuntu system

    o  Open a terminal and execute
            sudo apt-get install  libqt4-dev libqscintilla2-dev  (thanks to Tatsuro)
            sudo apt-get install  libportaudio-dev  libqt4-opengl-dev (thanks to Chechu)

    o  CD into your Octave directory and execute
        Verify that you don't receive a "Qt libraries not found -- disabling GUI" message.

    o  Execute
        This takes about two hours on my old PC

    o  Execute
              sudo make install
        This only takes a few minutes.

 (I'm not sure that libportaudio-dev is the correct library Octave needs in the third step, but having it seems to do no harm.)

Is there a better place than the maintainer's list to post this summary?  If so, it might save the next fellow a lot of time :-)

Curt Carpenter

On 06/11/2015 03:19 PM, Chechu Garguez wrote:

Le 11 juin 2015 22:08, "Curt Carpenter" <address@hidden> a écrit :
> I tried to sudo apt-get install portaudio-dev and libqt-gl-dev as suggested, and in both cases apt was unable to locate the files.
> Thinking that the file names might be wrong, I installed libportaudio-dev adn libqtgtl-dev in hope that they were the right files -- but still get the same "Qt libraries not found -- disabling GUI" message from Octave configure.
> Now I find that I'm unable to reinstall Octave 3.8.1 and execute --force-gui with it :-(.
> Any other ideas would be welcomed.

Good evening.
I miswrote the package name on my previous mail.
On ubuntu 14.04 Trusty it should be necessary to install :


Please try again the configure process after that install.
Yours sincerely Chechu

reply via email to

[Prev in Thread] Current Thread [Next in Thread]