[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: arduino package testing

From: John Donoghue
Subject: Re: arduino package testing
Date: Fri, 26 Apr 2019 18:36:34 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.4.0

On 4/26/19 3:00 PM, JohnD wrote:

From: Doug Stewart [mailto:address@hidden
Sent: Friday, April 26, 2019 1:30 PM
To: JohnD
Cc: Octave Maintainers List
Subject: Re: arduino package testing

On Fri, Apr 26, 2019 at 12:51 PM JohnD <address@hidden> wrote:
Whoops – should be
arduinosetup(‘libraries’, listArduinoLibraries('core'))

the single quotes were still wrong.
arduinosetup('libraries', listArduinoLibraries('core'))
this worked.

I got

   PASS                              135
   FAIL                                8

Running on my setup, I can get it programmed without the rotary encoder if I use default libraries, but if I run as:

arduinosetup ('libraries', listArduinoLibraries('core'))

.. It programs the rotary endcoder as well.

Note that currently, if the propertyname isnt a known one (ie: was spelt wrong) it will silently ignore it, which would then mean it would program the default libraries (ie: no rotary encoder)

When the arduino IDE is open, it you look at the sources settings.h file, there should be an uncommented #define USE_ROTARYENCODER

reply via email to

[Prev in Thread] Current Thread [Next in Thread]