[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: arduino package testing

From: Doug Stewart
Subject: Re: arduino package testing
Date: Tue, 4 Jun 2019 23:40:39 -0400

On Fri, May 3, 2019 at 12:40 PM JohnD <address@hidden> wrote:

From: Doug Stewart [mailto:address@hidden]
Sent: Tuesday, April 30, 2019 10:45 AM
To: John Donoghue
Cc: Octave Maintainers List
Subject: Re: arduino package testing

On Sat, Apr 27, 2019 at 7:37 PM Doug Stewart <address@hidden> wrote:

On Fri, Apr 26, 2019 at 6:36 PM John Donoghue <address@hidden> wrote:
On 4/26/19 3:00 PM, JohnD wrote:
> From: Doug Stewart [mailto:address@hidden]
> Sent: Friday, April 26, 2019 1:30 PM
> To: JohnD
> Cc: Octave Maintainers List
> Subject: Re: arduino package testing
> On Fri, Apr 26, 2019 at 12:51 PM JohnD <address@hidden> wrote:
> Whoops – should be
> arduinosetup(‘libraries’, listArduinoLibraries('core'))
> the single quotes were still wrong.
> arduinosetup('libraries', listArduinoLibraries('core'))
> this worked.
> I got
> Summary:
>    PASS                              135
>    FAIL                                8
Running on my setup, I can get it programmed without the rotary encoder
if I use default libraries, but if I run as:

arduinosetup ('libraries', listArduinoLibraries('core'))

.. It programs the rotary endcoder as well.

Note that currently, if the propertyname isnt a known one (ie: was spelt
wrong) it will silently ignore it, which would then mean it would
program the default libraries (ie: no rotary encoder)

When the arduino IDE is open, it you look at the sources settings.h
file, there should be an uncommented #define USE_ROTARYENCODER

Here is a little scope prog that I wrote 

I will see what I can find about the rotaryencoder and report here.

I found this in the file called octave:

#include "OctaveRotaryEncoderLibrary.h"
OctaveRotaryEncoderLibrary lib5(octavearduino);

so it should work.

I did not find a file called: settings.h


Can you verify that:

> listArduinoLibraries('core')

returns with rotaryencoder in it

and then retry running:

> arduinosetup ('libraries', listArduinoLibraries('core'))

reprogram it, and verify that

> a = arduino()

Then lists rotaryencoder as one of its libraries

I did get it to work and all tests pass.
DASCertificate for 206392

reply via email to

[Prev in Thread] Current Thread [Next in Thread]