[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: portable termina

From: John W. Eaton
Subject: Re: portable termina
Date: Wed, 29 Jul 2020 19:53:42 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

On 7/29/20 4:09 PM, Rik wrote:

A separate problem that I see is that when I'm starting Octave from a remote system it doesn't open the terminal window.  I'm not sure what's happening there.  I have a terminal window open on my desktop system running ssh to connect to another system with X forwarding through the ssh connection.  My DISPLAY is set properly.  The Octave GUI and Plot windows open correctly. Executing

  system ("emacs", false, "async")

opens a new Emacs window.  But

  system ("x-terminal-emulator", false, "async")

does not.  Weird.

Does it work if you use the name of the binary exactly (gnome-terminal)?  There might be something strange about going through a symbolic link.

It still fails with gnome-terminal. I see now that if I wait long enough (about a minute?) it eventually displays the message

# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

I did some searching and found some old discussions about this issue but nothing I've tried so far has fixed it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]