[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-patch-tracker] [patch #7929] Partial Differential Equation Solve

From: Mark Wistrom
Subject: [Octave-patch-tracker] [patch #7929] Partial Differential Equation Solver in two dimensions
Date: Tue, 22 Jan 2013 01:34:49 +0000
User-agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

Follow-up Comment #2, patch #7929 (project octave):

The five pdex# examples for Matlab's pdepe function work for my code and seem
to produce the same results. The 10 examples from the SB paper produced mixed
results when compared with the exact analytical solution which were provided.
The biggest surprise is that the error from MATLAB's implementation (tested on
R2011a) is about an order of magnitude worse than my code for the examples
where there is a singularity. This is interesting because the entire purpose
of the paper was to provide a general PDE solver for the cases where there is
a singularity. I'm not sure what MATLAB did, but their errors are clearly
larger and they have some irregular jumps/features in the error near the
origin that are absent from my code. Perhaps this from user error or something
else I did, but I am at a loss to explain or fix it.

The examples are numbered by their subsection from the paper. The comparisons
between the two implementations are below:

SB11  m=0  
Both produce the same result

SB21  m=2
SB25  m=1
Matlab says that the index is too big. daspk returns without being able to
find initial conditions.  No solution.

SB22  m=2
SB23  m=2
SB26  m=1
SB28  m=1
In these four examples Matlab produces a solution that is about an order of
magnitude worse than my solution and has strange features around the origin. 
NOTE: There is a typo in the analytical solution for SB23, 4xt should be 6xt.

SB24  m=2
Solvers generally give the exact solution for this problem and my code does.
Matlab states that the index is too big.

SB27  m=2
my code and Matlab produce the same strange (incorrect) solution. I do not
know why.

SB29  m=1
Mathematica, Matlab and my code produce the same result which is quite
different from the exact solution given in SB. I checked that the exact
solution solves the equation.  I do not know what is going on here.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]