[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Pan-devel] Re: yes, ./ needs rerun

From: SciFi
Subject: [Pan-devel] Re: yes, ./ needs rerun
Date: Wed, 27 Oct 2010 09:10:31 +0000 (UTC)
User-agent: Pan/0.133 (House of Butterflies; GIT e3cb864 testing; i386-apple-darwin9.8.0 / gcc-4.2.1 (Apple build 5577))


On Mon, 25 Oct 2010 22:20:24 -0600, K. Haley wrote:
> On 10/24/2010 10:05 AM, SciFi wrote:
>> Hi,
>> I am now running your code almost 100% 
>> with the patch I mentioned on Aug.27/28 archived at these places:
>> <news:pan.2010.>
>> <>
>> <>
> I'm wondering if it's a gcc bug in the osx port.  It doesn't really
> matter since that flag is never set.  I've just rebuilt and pushed
> testing with that and the xface inversion fix.

It just so happens that I have the entire saved Gmane archive of
this mail-list (pan-devel), and this particular bug/patch began
in the thread archived at these places:


(more than a year ago as of this message/post)

Yes, as implied, the actual bug-report filed (mentioned in my post
and included in my patch) indicates the original system was Ubuntu,
not OSX.  Of course we–all might have similar gcc bugs, but I do
wonder why.  ;)  [In times past, I have tried to build newer
versions of gcc/family, but it was a hopeless affair when it comes
to actually _using_ that new generated code under OSX.  :(  Any
more, we plead with Apple to update Xcode and/or OSX officially.]

As I tried to mention, the bug seems to rarely occur, but when
it does, a subsequent get-new-headers will usually not make it
occur again, until/unless _another_ header invokes the bug.
Yet sometimes that does occur, too, sometimes in spades, and
like I said, it seems to happen more often when a “new school
season” is underway (my observation, which my gut tells me,
some things related).

I don’t know if another situation I’m experiencing is related:
At least Giganews seems to have a ’bot of some kind, that gives
Pan an “Unknown Error” at certain times during any 24–hour
period, even when I’ve told Pan to go off-line.
This is certainly GN sending us some kind of packet, it isn’t
Pan deciding on its own — once in a while, we use the
‘yencee’ project at Sourceforge to post files, and GN
sometimes causes it to error–out at seemingly random times
but actually within the time–periods of the “Unknown Error”.
I’ve had chats with its developer to rewrite ‘yencee’ to do
another full login and commence where it was stopped, which
seems to fix that particular problem.
I surmise Pan is doing something similar (another full login).

I just wish there was _some_ way we could track these kinds
of random problems that do re-occur.  In this case I believe
having an accurate clock (NTP source) would be a key method to
communicate with GN’s operators.

At any rate, thank you and others for taking time to chat
about these issues.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]