[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] Using MaxStream API mode with 2.4ghz XBeePro OEM modul

From: david
Subject: [Paparazzi-devel] Using MaxStream API mode with 2.4ghz XBeePro OEM modules
Date: Thu, 10 Apr 2008 17:00:05 GMT


From the aircraft files, namely funjet1.xml I see XBeePro (xbee) as the modem 
used there. I saw lots of mention about the MaxStream product on the Wiki. So I 
chose to do our first aircraft using XBeePro 2.4ghz modules. I was thinking 
this way the first attempt will be easier as it's a well tested aircraft 
(FunJet) and components (Berg4L), Hitec HS55 servos, MaxStream 2.4ghz RF modem 
module in aircraft and MaxStream 2.4ghz USB modem on ground station. I liked it 
had the removable small antenna on the USB one to justify the expensive cost of 

Has anyone flashed the ground station Modem (XBP24-PKC-001-UA) using Linux 
only? I realize I need to tell that modem to use 57600bps if I am using that 
speed in the module. I do not use Windows (Ubuntu 7.10 and Mac OSX 10.5). So, 
it is PnP recognized as /dev/ttyUSB0 as expected. But now how to set the values 
the same as the module?

I tried:
 1. echo 'ATPL2\rATRN1\rATTT80\r\ATBD6\rATWR\r\' </dev/ttyUSB0 and saw the 
green light blink once quickly on the left (receive).
 2. I did the exact steps in the Wiki for configuring the Module for API and 
57600 (funjet1.xml based aircraft file, tiny2.11 autopilot)
 3. As soon as I power up the Tiny2.11 the lights on the ground station modem 
light up. Three green on the right and the top left yellow is rapidly blinking 
and the lower left red is on. It appears they are communicating.
 4. I launch GCS and get screen (expected at this point) and no 
telemetry...not expected.

I have successfully used 9600bps and everything worked. Just now nothing with 
57600. Any ideas? Surely all who have changed from 9600bps to 57600 and to the 
API protocol have had to do this same thing.

Is there anything I can send to help with the debugging I didn't list? 
Bootloade and programming go without any issues.

David Conger

reply via email to

[Prev in Thread] Current Thread [Next in Thread]