[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Re: Can't get GCS to populate

From: Felix Ruess
Subject: Re: [Paparazzi-devel] Re: Can't get GCS to populate
Date: Wed, 18 Mar 2009 18:35:30 +0000

Hi Alston,

you have to configure one of your XBees as a coordinator (I would suggest the ground station as a coordinator). Every coordinator sets up a PAN (Personal Area Network) with an ID. You can choose any ID but you have to set the ID on the EndDevice to the same one. The End device will then connect to the coordinator with that PAN ID. You should also set a node identifier for each modem.
I also (very briefly) described that here:
The ZNET 2.5 is basically just the older version of the Pro ZB, same principle.



2009/3/18 Alston Pike <address@hidden>
I originally had the correct UARTs set and changed them in a desperate attempt to get the gcs populating.  I reset them back to how they originally were (serial as uart1 and gps as uart0).
My downlink_serial_port value was already set as /dev/ttyUSB0, as was the device flag in my data link.  I confirmed the correct address with the tail command, added the -uplink line and made sure the transport was set to pprz.
Still nothing.
I've checked the baud rates the modems are using through XCTU.  Both are set as 9600 baud.  I confirmed I had my airframe and data link configurations matching.  I also restored the "default" configurations to the modems.  The function set in XCTU that I'm using (on both modems) is ZNET 2.5 ROUTER/END DEVICE AT.
At this point, I'm at a total loss.

Alston Pike
BSME 2009
The University of Alabama
(706) 594-2812

On Tue, Mar 17, 2009 at 12:19 AM, David Buzz Carlson <address@hidden> wrote:
First you need to be sure that you are using the correct UART for the Tiny you have.  For Tiny v2, looking at the pinout, "Serial" is UART1 and "Download" is UART0.

Once you are sure you have the correct UART in your airframe (and make sure GPS and Downlink aren't trying to use the same one!), find out where the FTDI cable is being attached.  Run "sudo tail -f /var/log/messages" and then plug in the FTDI cable.  You should see something like:

>   usb 4-1: FTDI USB Serial Device converter now attached to ttyUSB0

This tells you that the FTDI bound to /dev/ttyUSB0.  Check that your session is using the correct port.  Run "grep downlink conf/control_panel.xml" from the paparazzi directory and make sure it prints out this:
>  <variable name="downlink_serial_port" value="/dev/ttyUSB0"/>

The next thing is to make sure that your session is using the right serial port.  In that same file, you will see the different sessions you can run.  To use the FTDI cable, a particular session would need this line:
    <program name="Data Link">
      <arg flag="-d" constant="/dev/ttyUSB0"/>
      <arg flag="-transport" constant="pprz"/>
      <arg flag="-uplink" constant="" />
      <arg flag="-s" constant="57600"/>

You need to set the -s flag to whatever baud you've configured in your airframe file.
The final thing is to make sure you aren't trying to use API messages while using the FTDI cable.  Make sure everything is set to PPRZ transport and transparent.

Hope this helps,

Alston Pike wrote:
Sorry for the delay in the response...

I've switched the uarts for the gps & modem link back to the original values (gps on 0 & modem on 1).  Still no luck.  I tried loading the development version of the software on my personal laptop under ubuntu 8.04 and still have the same problems I was having before.

Could the problem be a device problem? I'm using /dev/ttyUSB0 as my device on the data link as opposed to /dev/paparazzi/ttyUSB0.  I checked the /dev/paparazzi directory and the only thing that was listed was a device simply called serial.

Thanks again.

Alston Pike
BSME 2009
The University of Alabama
address@hidden <mailto:address@hidden>
(706) 594-2812

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]