[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] Re: no uplink with xbee pro version 2

From: Paul Cox
Subject: [Paparazzi-devel] Re: no uplink with xbee pro version 2
Date: Tue, 5 May 2009 07:35:14 -0700

Salut Loic,

Before switching to aerocomm modems for better range, I used xBee Pro 2.4 modems (version 2, I believe. I can get you the exact part number). I used the factory settings (no MAC addresses or any specific configuration data programmed) and the modems automatically communicated with each other without any issue. From your text it looks like you're configuring the modems with AT commands and maybe instead you could try the default factory settings to see if this odd symptom disappears. Also, you might look at what serial link protocol your tiny is currently using. It can assume the link is just a simple serial link (which is called PPRZ protocol) or a XBee/Maxstream modem (which is called XBEE protocol, I think). This is set in the makefile portion of the airframe file and there is some sample configs of that option on the wiki. The fact that the range test works fine means your base station modem is probably ok electrically, but if the AC modem is not responsive maybe stick a scope on TX/RX (all the way to the LPC2148 pins) and see if you can ensure all is well there.

Bonne chance,



Message: 5
Date: Fri, 01 May 2009 19:17:23 +0200
From: Lo?c Raffard <address@hidden>
Subject: [Paparazzi-devel] no uplink with xbee pro version 2
To: address@hidden
Message-ID: <address@hidden>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed


We are a group of student from the Isae/Supaero in Toulouse and we are
trying to fly a Twog equipped aircraft.

Our problem is that in using xBee Pro 2.4 gHz version 2 we only have a
downlink but no uplink. Has anybody encountered something like that
before? Our  modems are configured using X-CTU and are set on 9600
bauds. For the ground modem we tried Xnet 2.5 coordinator AT and for the
aircraft modem end device/ router AT  with the same Pan ID and different
node name, we also tried Zigbee coordinator At for the ground modem and
End device At or Router AT but we always had a downlink but no uplink.

We also tried to put our old Radiotronix modem and this time it worked
both uplink and downlink using the same .xml for paparazzi center.

In X-Ctu the modem with the coordinator is working when we use the Range
Test but not the one in the aircraft.I don't know if it's normal.

Thank you very much

loďc Raffard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]