[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] What's wrong with throttle control?

From: Steven Wawryk
Subject: [Paparazzi-devel] What's wrong with throttle control?
Date: Wed, 10 Jun 2009 19:15:41 +0930
User-agent: Thunderbird (X11/20090318)


I'm trying to get a flight plan to partially spool up the throttle before launch but I can't seem to get the pre-launch throttle to any values other than 0% or 100%.

When I set it to 0, the GCS reports 0%, when I set it to *any* non-zero value, the GCS shows it slewing up to 100%. It only seems to be boolean until a control loop sets it after launch. This happens for both sim and ap targets. With ap, the throttle servo confirms it.

I've tried it using <attitude roll="0.0" throttle="0.5" vmode="throttle" until="suds_cld_launch_detected"/>, with other vmodes and by setting each of v_ctl_throttle_setpoint and ap_state->commands[COMMAND_THROTTLE] to MAX_PPRZ/2, but all give the same result.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]