[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Sim compilation error

From: Gareth Roberts
Subject: Re: [Paparazzi-devel] Sim compilation error
Date: Mon, 01 Nov 2010 17:48:54 -0000
User-agent: Opera Mail/10.63 (MacIntel)

Thanks Martin and Felix,

No airframe file, this is a first build, as in compiling GCS - I installed paparazzi-dev and friends, then did a fresh svn checkout and just did a make clean && make in the root of the paparazzi folder.

I don't know why compiling GCS needs messages.h but apparently it does. I get a messages.h in my tmp folder, but I've tried manually copying it to $PAPARAZZI_HOME/var/include/messages.h and no dice.

No special environmental settings in the chroot - I'm using schroot set up as per the ubuntu wiki, which I've done before for using paparazzi on x84_64 and it usually works ok - if you think that could be the problem though I can provide more details. Most of the compilation goes perfectly, it fails at the sitl stage fairly late on in the compile process. If you would like a full log please let me know, although I won't be able to provide one until tomorrow when I'm back in work.


On Mon, 01 Nov 2010 17:01:38 -0000, Martin Mueller <address@hidden> wrote:

Hi Gareth,

could you attach your airframe file? The error is a little unspecific and I don't see that.


On 01.11.2010 17:13, Gareth Roberts wrote:
Hi Martin,

I'm getting a similar problem with a fresh new checkout, the first make
fails with

BUILD /home/me/Sources/paparazzi3/var/include/messages.h
Exception: Not_found.
make: *** [/home/me/Sources/paparazzi3/var/include/messages.h] Error 2

address@hidden:~/Sources/paparazzi3$ svn up
At revision 6319.

I am building in a chroot, but I've done that before and it worked fine.
Up to date lucid i386 in the chroot.


On Fri, 29 Oct 2010 20:56:34 +0100, Helge Walle <address@hidden> wrote:


I just updated to revision 6305. Did make clean and make.

When I tried to build a sim target I got these lines:

arch/sim/sim_adc_generic.c:2:25: asm or __attribute__ before
arch/sim/sim_adc_generic.c: In function update_adc1:
arch/sim/sim_adc_generic.c:14: error: adc_generic_val1 undeclared
(first use
in this function)
arch/sim/sim_adc_generic.c:14: error: (Each undeclared identifier is
reported only once
arch/sim/sim_adc_generic.c:14: error: for each function it appears in.)

I used the same configuration files that was successfully used in a
simulation just a few days ago.

Building the ap target seems to work fine.

Any hint of what might be the problem?

Thanks in advance for any help,


Paparazzi-devel mailing list

Paparazzi-devel mailing list

Using Opera's revolutionary email client:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]