[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Luftboot new version

From: Gerard Toonstra
Subject: Re: [Paparazzi-devel] Luftboot new version
Date: Thu, 27 Sep 2012 20:05:56 -0300

Well.. not getting anywhere with the tests for now, I decided to attempt flashing the bootloader, so I don't
have to use the bootloader wire anymore on ADC2.

I'm getting errors. Could be an indication there's some more stuff going wrong.

- First tried to flash through paparazzi as follows.
- I've got the black magic probe connected with the black JTAG plus the serial cable.
- I've modified the config to flash luftboot by configuring JTAG etc.:

    <configure name="FLASH_MODE" value="JTAG"/>
    <configure name="NO_LUFTBOOT" value="1"/>
    <configure name="BMP_PORT" value="/dev/ttyACM0"/>


make[1]: Leaving directory `/work/paparazzi/sw/airborne'
cd sw/airborne; make PAPARAZZI_SRC=/work/paparazzi PAPARAZZI_HOME=/work/paparazzi TARGET=ap upload
make[1]: Entering directory `/work/paparazzi/sw/airborne'
Assuming luftboot bootloader: no
Using Black Magic Probe with JTAG on BMP_PORT /dev/ttyACM0
Using GDB = /opt/paparazzi/arm-multilib/bin/arm-none-eabi-gdb
  BMP    /work/paparazzi/var/Maja/ap/ap.elf
Target voltage: 3.3V
Device  IR Len  IDCODE      Description
0    4    0x3BA00477  ARM Limited: ADIv5 JTAG-DP port.
1    5    0x06418041  ST Microelectronics: STM32, Connectivity Line.

Available Targets:
No. Att Driver
 1      STM32, High density.
0x080023b2 in __ieee754_asinf (x=0) at ../../../../../../../src/gcc-linaro-4.6-2011.09-1/newlib/libm/math/ef_asin.c:61
61    ../../../../../../../src/gcc-linaro-4.6-2011.09-1/newlib/libm/math/ef_asin.c: No such file or directory.
    in ../../../../../../../src/gcc-linaro-4.6-2011.09-1/newlib/libm/math/ef_asin.c
/work/paparazzi/sw/tools/flash_scripts/bmp_jtag_flash.scr:3: Error in sourced command file:
Error erasing flash with vFlashErase packet
make[1]: Leaving directory `/work/paparazzi/sw/airborne'
make: Leaving directory `/work/paparazzi'

DONE (exec make -C /work/paparazzi -f AIRCRAFT=Maja ap.upload  2>&1)

Then I figured... let's try by using the make flash commands from luftboot itself.
- Downloaded luftboot as per the link here
- Figured out to set PATH to the "bin" in the /opt/paparazzi/bin directory
- Downloaded latest libopencm3, set LIBOPENCM3 to correct directory.
- Spotted that the .a file was created in /lib, but not in stm32/f1. Copied to that dir instead
- Ran make again, this time it worked. Then tried to flash using the BMP_PORT="/dev/ttyACM0" again. result:

address@hidden:/work/luftboot/src$ make flash DEV_SERIAL="LM2-152" BMP_PORT="/dev/ttyACM0"
Using Black Magic Probe
Using GDB = /opt/paparazzi/arm-multilib/bin/arm-none-eabi-gdb
  BMP    luftboot
Black Magic Probe (Firmware 1.5-gbad49db, build 20120527)
Copyright (C) 2011  Black Sphere Technologies Ltd.
License GPLv3+: GNU GPL version 3 or later <>

Target voltage: 3.3V
SW-DP detected IDCODE: 0x1BA01477
Available Targets:
No. Att Driver
 1      STM32, High density.
0x080023ae in ?? ()
../scripts/black_magic_probe_flash.scr:4: Error in sourced command file:
Target does not support this command.

Am I doing something horribly wrong here?  Wrong libopencm3 version?  Hardware issues?


On Sun, Sep 23, 2012 at 11:35 AM, Sergey Krukowski <address@hidden> wrote:
Hi guys!
I've just tested the new version of Luftboot on the LisaM v2 and it works. There is now an USB cable detection implemented, so you can boot up the Luftboot bootloader without an bootloader connector, just plug the USB and turn on the power. It also switches to the app after the upload.
You can download either the binary file from here
or the complete source code from my Luftboot forked repo here
If there is any questions, I'm always ready to help.

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]