[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] constant drift in Eular Stab. and QFU in auto take

From: Felix Ruess
Subject: Re: [Paparazzi-devel] constant drift in Eular Stab. and QFU in auto take-off
Date: Mon, 9 Sep 2013 17:42:00 +0200


i have flame wheel quad with lisa/m ,paparazzi 4.9devel (version right before 5stable)

In general I would recommend to use the latest stable branch (v5.0) or master if you are a bit adventurous and want to test new features and improvements.

1. when flying with Euler stability and int_cmpl_quat AHRS i get a constant drift of about 20 deg. forward.
 when the quad is leveled on the floor  and an inclination meter confirms it, the PFD is also leveled.
messages rotorcraft_fp shows 0 offsets.
with int_quat stability it works ok.
what could cause this ?

This is really hard to say without knowing your airframe configuration... and when do you get this "drift" flying in manual attitude mode, in auto2 navigation, or?
i want to use the Eular stability because the quad handles much much better then with int_quat (same PID values), where it looks like it's vibrating a lot, no matter how much i've tried tuning the PID on a test bench

First a note about the PID values: since these are different controllers, don't expect that the same PID values will yield the same result in euler and quaternion stabilization.
About the int_quat stabilization, there have been some quaternion reference scaling fixes in the master branch that should make it work properly again.
So you might want to give it a try.
2. if i trying to take-off automaticaly ,and it gets up to standby mode and staying there fine,
but ,if i put the nose not to the west ,the quad starts the motors and trying to yaw on the floor t aggresively (looks like quad doing breakdance on one arm ;)
some times its getting fliped upside down...
i've done many tryouts, and pointing the nose to the west solves the problam ,is it like the QFU in the fixedwing ?
how can i solve it ?

Hm.. that's weird and definitely not how it's supposed to be. There is no QFU, it should just keep the same heading that you had when powering on.
Didn't have any problem like this before (and currently works for me in master).
Do you directly start in NAV mode? Is your magnetometer calibrated and heading working correctly?
Can you check the desired heading in GCS -> settings -> nav -> nav_heading?

Cheers, Felix

reply via email to

[Prev in Thread] Current Thread [Next in Thread]