[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Lisa/M bootloader.

From: Karoly Molnar
Subject: Re: [Paparazzi-devel] Lisa/M bootloader.
Date: Sat, 2 Nov 2013 08:21:44 +0100

Hi Stephen / Piotr

Thanks for the explanations. Now its clear, I understand that both features are tightly related to allow the USB plugged in to PC and still let the payload code execute. Fair enough.

I have made a fork of luftboot to add gateway features and the 8K memory space of luftboot has become tight quickly. So I had to lean out the startup condition check as I wrote in my first mail. I have also deleted the flashing of option registers for similar reasons (ran out of space, did not find the rationale, fundamental functionality still works without it).


Date: Fri, 1 Nov 2013 23:27:59 -0600
From: address@hidden
To: address@hidden
Subject: Re: [Paparazzi-devel] Lisa/M bootloader.


Karoly, also, there is an extra feature to check for some internal registers so one can jump into bootloader mode from the application payload through a reset. It is kind of a hack but not bad. Probably better to use BKP domain registers...

Having the bootloader disable jumper is rather useful in bench testing, as Piotr mentioned.

-Stephen Dwyer

On Fri, Nov 1, 2013 at 4:28 PM, Piotr Esden-Tempski <address@hidden> wrote:
This is the case in the current version of luftboot. With one exception that if the boot pin is grounded the check if the usb cable is plugged in is being ignored.

This makes it possible to develop and test firmware on your desk using the USB cable to provide power, removing the need of having a separate power supply.

On Nov 1, 2013, at 2:27 PM, Karoly Molnar <address@hidden> wrote:

Hi Piotr,

Could you please help me to understand the startup procedure of luftboot. I see that the luftboot is checking multiple conditions to detect if the payload or the boot loader shall be started. Couldn'tit be reduced to a simple double condition as: 
1. Start the payload if:
1.a Valid payload can be detected and
1.b No USB cable is detected
2. If 1.a or 1.b is not met, stay in luftboot

What was the rationale behind the more complicated solution? Is there a use case that I do not see?


From: address@hidden
Date: Fri, 1 Nov 2013 12:42:22 -0700
To: address@hidden
Subject: Re: [Paparazzi-devel] Fwd: Lisa/M bootloader.

Hi Helge,

I think you just have an older version of the bootloader. The toytronics branch has a provision in the firmware that detects the usb cable and launches the bootloader. Master does not have it because it is now built in into the bootloader itself.

It should be enough that you jump the boot pin before powering up and the bootloader will not launch the payload and allow you to upload a new version of your firmware.


On Nov 1, 2013, at 10:36 AM, Helge Walle <address@hidden> wrote:


Today I wanted to install my Lisa/M v2.0, borrowed from my Quadshot Espresso, into a fixedwing setup. I made an airframe file for it, it is attached to this email.

I checked out v5.0 and built the firmware. On powering up Lisa/M, it went into bootloader mode as soon as I had connected both ends of the usb cable. The firmware was uploaded without problems. Everything worked fine after recycling power, and I got Telemetry. This is what happened every time I uploaded Quadshot firmware.

I wanted to use another radio file, so I changed that and built the firmware again. Now, when I connected the usb cable for the second time, Lisa wouldn’t enter bootloader mode. Nothing in dmesg indicated that any usb device was connected. Upload did not find any bootloader.

I rebuilt the code again, tried with another PC and another cable, checked that usb delivers voltage to Lisa, no success. Lisa won’t enter bootloader mode.

Could it be that the bootloader was overwritten? Everything worked perfectly first time when I had switched from the toytronics branch to v5.0

If I have to get a JTAG adapter to fix this, it seems I need the serial number of my Lisa/M. Where do I find that?
But I cannot understand what caused this...

Thanks for any help,


RUN 'make -C /home/helge/paparazzi -f AIRCRAFT=SKYWALKERHW_SPFUNIMU clean_ac ' 
make: Entering directory `/home/helge/paparazzi' 
rm -fr /home/helge/paparazzi/var/SKYWALKERHW_SPFUNIMU 
make: Leaving directory `/home/helge/paparazzi' 

DONE 'make -C /home/helge/paparazzi -f AIRCRAFT=SKYWALKERHW_SPFUNIMU clean_ac' 

RUN 'make -C /home/helge/paparazzi -f AIRCRAFT=SKYWALKERHW_SPFUNIMU ap.compile ' 

make: Entering directory `/home/helge/paparazzi' 
Paparazzi version v5.0.2_stable-11-g4b6ac49 
Current size: 
/home/helge/paparazzi/var/SKYWALKERHW_SPFUNIMU/ap/ap.elf : 
section size addr 
.text 0x1dd74 0x8002000 
.data 0x3760 0x20000000 
.bss 0x1578 0x20003760 
.debug_info 0x35db5 0x0 
.debug_abbrev 0x93b4 0x0 
.debug_line 0x1396e 0x0 
.debug_str 0x8f31 0x0 
.comment 0x3c 0x0 
.ARM.attributes 0x31 0x0 
.debug_loc 0x18b95 0x0 
.debug_aranges 0x2148 0x0 
.debug_ranges 0x4a70 0x0 
.debug_frame 0x46a0 0x0 
Total 0xa22ae 

make[1]: Leaving directory `/home/helge/paparazzi/sw/airborne' 
make: Leaving directory `/home/helge/paparazzi' 

DONE 'make -C /home/helge/paparazzi -f AIRCRAFT=SKYWALKERHW_SPFUNIMU ap.compile

Paparazzi-devel mailing list

_______________________________________________ Paparazzi-devel mailing list address@hidden
Paparazzi-devel mailing list

Paparazzi-devel mailing list

_______________________________________________ Paparazzi-devel mailing list address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]