[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Navigation routines as modules and cleanup

From: alonso acuña
Subject: Re: [Paparazzi-devel] Navigation routines as modules and cleanup
Date: Tue, 12 Nov 2013 19:52:09 -0600

I have been using the poly_survey_adv. I think you meant PolygonSurvey instead of poly_survey?  These are quite different in regards to the why the flight is done.  I am not sure that PolygonSurvey is useful really. Also I think we should remove the "adv" word,  I wouldn't say one is more advanced, they are just different.  So what you say of having only one would be a good idea and I would propose that the one you use is poly_survey_adv.  If someone thinks PolygonSurvey is useful then I think there could not be just one and new names would be required to differentiate them.

The poly_survey_adv is good when there is strong wind because you can fly slowly into the wind when taking photos then the return trip in the direction of the wind is not used. If there is not much wind then the return trip is just wasted. I am not sure if this can be fixed and keep just this one function or this one can be kept for strong wind and a new one can be made for when there is no strong wind.

On Tue, Nov 12, 2013 at 2:07 PM, Felix Ruess <address@hidden> wrote:
"load" is already used to load/add a module in the airframe file, so maybe not the best choice.
Prepare or prep sounds good to me, I guess setup would also be fine.

And I agree with Loic: the most important thing is to just have it properly documented in the end...

Is there anyone with experience in using the old OSAM poly_survey and poly_survey_adv (renamed to nav_survey_poly_osam and nav_survey_poly_adv for now)?
It would probably make sense to clean them up and only have one nav_survey_polygon in the end...

On Sat, Nov 9, 2013 at 11:11 AM, Loic Drumettaz <address@hidden> wrote:

"init" sounds good but isn't consistent with other init functions in the code.
"start" and "run" are fine,
other names are possible, we could add "compute" and "execute" to the list?
The most important is to have some examples.

Le 9 nov. 2013 04:38, "alonso acuña" <address@hidden> a écrit :

I think "setup" , "config" or "prepare" could work.

On Fri, Nov 8, 2013 at 4:02 AM, Chris Gough <address@hidden> wrote:

> We are still not sure what the best name for the start function is, feedback would be appreciated.

What about "load"?

Chris Gough
Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]