[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Phpgroupware-tracker] [bug #20284] Upgrade to MySQL 5.x causes MySQL 10

From: Robert
Subject: [Phpgroupware-tracker] [bug #20284] Upgrade to MySQL 5.x causes MySQL 1064 error when opening individual Forums.
Date: Wed, 27 Jun 2007 21:36:14 +0000
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20070515 Firefox/


                 Summary: Upgrade to MySQL 5.x causes MySQL 1064 error  when
opening individual Forums.
                 Project: phpGroupWare
            Submitted by: burnttoast
            Submitted on: Wednesday 06/27/2007 at 21:36
              Item Group:
                Category: phpgw-FUDForum
                Severity: 3 - Normal
                Priority: 9 - Immediate
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
       Component Version: CVS
        Operating System: GNU/Linux - Debian
         Reproducibility: Every Time
         Planned Release: None
           Fixed Release: 



I upgraded to MySQL 5.0.32 from the 4.x series. After the upgrade (and a cvs
update) I could not enter any of the forums.

My installation was working great before the upgrade, but I have already
solved the issue I ran across.

After upgrading to MySQL 5.0.32 I got an error which read:

1064: You have an error in your SQL syntax; check the manual that corresponds
to your MySQL server version for the right syntax to use near 'reads FROM
phpgw_fud_fc_view v INNER JOIN phpgw_fud_forum f ON ' at line 1

Apparently the term "reads" in this query is supposed to be used to assemble
the list in some fashion, but as of sometime in the MySQL 5.x series the word
"reads" became a reserved word or function which MySQL attempts to process
directly. Changing the word "reads" to "pulled" (or any other
non-reserved/special word) in these queries takes care of this problem

I found the term reads in these files:
../fudforum/setup/base/src/ Line 38:
../fudforum/theme/default/msg.php: Line 98:
../fudforum/theme/default/thread.php: Line 26:
../fudforum/theme/default/threadt.php: Line 26:
../fudforum/theme/default/tree.php: Line 110:

and changed it to "pulled" and now the installation works as intended.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]