[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [platform-testers] [Grep-devel] new snapshot available: grep-2.25.10

From: Bruce Dubbs
Subject: Re: [platform-testers] [Grep-devel] new snapshot available: grep-2.25.101-be82
Date: Mon, 26 Sep 2016 22:48:55 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39

Jim Meyering wrote:
On Mon, Sep 26, 2016 at 10:04 AM, Bruce Dubbs <address@hidden> wrote:
Jim Meyering wrote:

On Sun, Sep 25, 2016 at 11:27 PM, Bruce Dubbs <address@hidden>


Builds clean with gcc-5.3.0.

Thank you for the quick testing and the reports.

When I ran the expensive tests I had a failure.
FAIL long-pattern-perf (exit status: 1)

It appears to be a timing issue.

$ lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 94
Model name:            Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
Stepping:              3
CPU MHz:               3201.000

Thanks for the report.

How did you configure/compile that?

./configure && make && make check-very-expensive 2>&1 |tee ck.log

This test runs grep with two
regexps. First it times the use of a shorter one, then it times the
use of a regexp whose byte count is 10 times larger than the first
one. The test requires that the latter duration be no longer than 20x
the duration of the first run. In your case, it actually took 80ms
longer than the 400ms that would be 20x.

As mentioned in its comments, that test is sensitive to load and
timing. Can you reproduce that failure consistently when running that
test in isolation? I.e., run this a few times:

   check -C tests TESTS=long-pattern-perf RUN_EXPENSIVE_TESTS=yes

I may end up changing it to run the quick one 5 times, and use the
minimum time to compare against the duration of the longer-running
command also being run 5 times (or until passing).

Using the above, I ran it about 6 times and it only passed twice. I do have several apps open but I have 'load average: 0.01, 0.06, 0.05'

$ free
              total    used    free      shared  buff/cache   available
Mem:        8051948 1724040 5279176      414404     1048732     5834340
Swap:       2097148  361760 1735388

  -- Bruce

reply via email to

[Prev in Thread] Current Thread [Next in Thread]