[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Rename the load command to source

From: Jose E. Marchesi
Subject: Re: [PATCH] Rename the load command to source
Date: Thu, 16 Jan 2020 00:11:52 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

    > Hi Darshit.
    >     As discussed and decided during the GNU Hackers' Meeting, Jan 2020, we
    >     should rename the "load" command to "source". This makes the verb be
    >     more in-line with what the command really does.
    > This looks good.
    >     This patch does not currently change the --load command line switch.
    >     Renaming it to --source is easy, but I don't like making the short
    >     switch -S or leaving it as -l. So I'm currently looking for ideas on 
    >     to deal with it.
    > So the question is what to do with the short switch.  What about not
    > having a short switch for that?
    Not having a short switch works fine. `--source` isn't a lot to type.

I'm actually having second thoughts about this.

Currently the semantics of the dot-command .load is to always try to
load the specified file.  This is useful in cases where loading the file
failed due to a compilation error.

Now, if we keep exactly the same semantics for the in-language `load'
construct, then it makes full sense to call it a load.  Of course this
means that if the same pickle (that contains definitions) is loaded
twice, a compilation error will arise, but thats life...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]