[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ISSUE] Building poke after latest patch.

From: Konstantinos Chasialis
Subject: [ISSUE] Building poke after latest patch.
Date: Mon, 29 Mar 2021 17:41:05 +0300
User-agent: SquirrelMail/1.4.23 [email.uoa.gr]


I am having troubles building poke on my mac (m1 processor) after the
latest patch where new changes to pk-mi-json.c/.h were introduced.

More specifically, I am facing the following issue :

Undefined symbols for architecture arm64:
  "_rpl_vsnprintf", referenced from:
      _jerror in poke-pk-mi-json.o
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see

I would like to point out that when I comment out the use of vsnprintf
poke builds successfully.

Also, when I use vsnprintf function on a custom .c file (i.e. test.c on
Desktop) it compiles successfully w/o the use of any external libraries.

Jose pointed out that I should add vsnprintf module to gnulib_modules,
which I did.
Unfortunately, I still get the same error.

Any ideas?

Thanks in advance,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]