[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: building on cygwin [Was: Re: pspp new bee]

From: unknown-1
Subject: Re: building on cygwin [Was: Re: pspp new bee]
Date: Tue, 15 Apr 2008 17:50:11 +0200

2008/4/15, John Darrington
On Mon, Apr 14, 2008 at 06:06:05PM +0200, unknown-1 wrote:
     My problems:

     - copy /usr/include/ncurses/term.h to /usr/include/term.h   (this looks as a
     bug somewhere)
     No idea why cygwin places this file in the include/ncurses directory and the
     make of pspp is looking in the include directory.

Thanks for reporting this.  I'll try to  address this in the
next pre-release tarball.  In  the meantime, a better work around
would be to use "CFLAGS=-I/usr/include/ncurses ./configure" when
configuring the build.

Ok. Your welcome.

     When I compile without "--without-gui" then the ./configure tells me:
     configure: error: The following required prerequisites are not installed.
     You must install them before PSPP cab be built:
             gtk+ 2.0 v2.12.0 or later (or use --without-gui)
             libglade 2.0 (or use --withput-gui)
     As far as I understand I have GTK+ 1.2.10-2 which is too old and libglade2
     2.5.1-1 which should be new enough if libglade=libglade2.

The 1.x and 2.x series of GTK+ are considered different libraries by
most packaging systems.  You need to install the one package with a
name similar to gtk2-x11-devel

You can find out which versions you have installed by typing

pkg_config --modversion gtk+-2.0
pkg_config --modversion libglade-2.0

Learning all the time. :-) In fact I tested this already with all packages installed.

pkg-config --modversion gtk+-2.0          result:  2.6.10
pkg-config --modversion libglade-2.0     result:  2.5.1

So I guess there is a bug in the test for the libglade version. Maybe it gives always this error when the gtk+2 version is to old?

Anyway my problem yet is the old gtk+2 version. In fact it is even to old for the PSPP version of november 2007. So I will have a look at cygwin to find out how I can get a newer version of gtk+2. (Or has anybody here a suggestion?)

Any answers are apreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]