[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Noob needs help with simple script

From: David Spaugh
Subject: Noob needs help with simple script
Date: Tue, 10 May 2011 22:09:17 -0700

PSPP version 0.7.5 running on Windows XP.
I wish to import a usgov NAMCS public data file into PSPP.
The data file is a single column of data with many rows.  Each row is a record; each record has multiple fields containing data. 
There are no delimiters or separators in the records; just a string of characters. 
There is however a record format that defines the list of data items and the field length and field location of each.
Example: the 1st 2 characters of the record are the month field, the next 4 characters are the year field, the next 1 is the day field, etc. 
I read the manual and have attempted to use the Get Data command.  When I run it, I get some processor activity, then nothing.  The application drops into the "Not responding" mode according to Windows. 
Here's a sample of my Script:
GET DATA /TYPE=TXT /FILE='C:\Documents and Settings\Owner\My Documents\WPI New\Papers\Research Data\NAMCS\2008 raw data\NAMCS08' /ARRANGEMENT=FIXED /FIRSTCASE=1 
  VYEAR 3-6 F
  VDAYR 7-7 F
  AGE 8-10 F
  SEX 11-11 A
  ETHNIC 12-13 A
  RACE 14-15 A.
*SAVE /OUTFILE 'C:\Documents and Settings\Owner\Desktop\NAMCS08Tue'.
I buried the Save command in asterisks to eliminate possible problems and focus on getting the file imported.  There are 25,000 rows in the file.  There are ~200 data elements within each record.  My actual script encompasses all fields, but I truncated it here for brevity. 
My objectives:
Import data.  Save as a new file.  Then do some basic sorting and rudimentary number crunching. 
If you can help me get this data file into PSPP, I'd be very grateful.  I have no idea why this isn't working.  I'm a complete amateur at scripts. 
I've eliminated all syntax errors, but the script still doesn't work.  I don't know if I'm missing required elements, or trying to open something that PSPP cannot open, or what. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]