[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Re[2]: Problems with PSPP on Windows7

From: Harry Thijssen
Subject: Re: Re[2]: Problems with PSPP on Windows7
Date: Fri, 24 Feb 2012 09:06:46 +0100

Hi Tom

Good, I can assure you that I can run much much larger datasets. So that can't be the problem.

What I am thinking on:
- are you running as administrator or with restricted rights on MSWindows?
- which version of MSWindows is it, Starter, Professional, Ultimate etc. MSWindows 7 has several versions maybe there is one with so much restrictions that it is hardly possible to use it for work.
- are you able to write on the temp directory and is there enough space?
- if you start psppire from a commandline with, most likely "c:\program files\pspp\bin\psppire.exe" and then do the things, are there any messages in the console?
- with "start" "all programs" "pspp" "examples" you land in a screen with .sps example files. What are the results if you run them?

Have fun

2012/2/24 Tom Gillaspy <address@hidden>
I seem to be making a bit of progress.  When I used a relatively small dataset less than a 1,000 cases, it ran just fine, test after test with no indication of freezing.  As soon as i loaded a larger database (around 50,000 cases which is no where near the limit of the program) it would run the first test and then freeze on the second, every time, regardless of test or database.  There is never an error message.  The journal file does not even list the last command sent.  Nothing seems to make a difference in this--not which command or specific database.  The result is always the same.  It seems to only hang up with statistical analysis.  Commands like WEIGHT do not seem to make a difference.

------ Original Message ------
From: "Harry Thijssen" <address@hidden>
To: "Tom Gillaspy" <address@hidden>
Cc: address@hidden
Sent: 2/22/2012 3:28:23 AM
Subject: Re: Problems with PSPP on Windows7

Did you try to run the syntax John proposed?

It should be easy. Copy/paste the syntax in a file "test.sps". In the
latest PSPP build you can start this file in the syntax editor by
clicking on the file. After that you click on "Run"  and then "all".

See what happens.

Have fun

2012/2/22 Tom Gillaspy

Thanks for responses.  I did find a "legacy" directory that was protected.
Logging on as Administrator I was able to finally delete that.  I
downloaded again from the site you note below.  Same thing happened.  I ran
a crosstab that ran fine and the second one froze the program.  It is almost
like something is wrong in the graphic interface.  i haven't tried with
direct commands yet.  However, running a volume of tests without the graphic
interface is really cumbersome.  I have a relative new system with Windows
7, plenty of memory, speed, etc.  I really don't think the data is the
problem since I have run several tried and tested databases with exactly the
same results.  I also don't think it is because I am not running LINUX.   I
checked with the PSPP log file and all it showed was the first set of
commands that executed.  There was no error message or indication that I had
done anything beyond the first crosstab.  It is almost as if it froze before
I entered anything else.   ------ Original Message ------
From: "Harry Thijssen" <address@hidden>
To: address@hidden
Sent: 2/21/2012 8:06:26 AM
Subject: Re: Pspp-users Digest, Vol 70, Issue 14

First of all, try the latest builds at:


Thanks for the response.  I have tried all the versions listed on

These files are the same. Actually links to the
files stored on sourceforge.

Have fun

Pspp-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]