qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v4 02/10] hw/sd/pl181: Rename pl181_send_command() as pl181_d


From: Alistair Francis
Subject: Re: [PATCH v4 02/10] hw/sd/pl181: Rename pl181_send_command() as pl181_do_command()
Date: Mon, 6 Jul 2020 08:46:57 -0700

On Sun, Jul 5, 2020 at 1:46 PM Philippe Mathieu-Daudé <f4bug@amsat.org> wrote:
>
> pl181_send_command() do a bus transaction (send or receive),
> rename it as pl181_do_command().
>
> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>

Reviewed-by: Alistair Francis <alistair.francis@wdc.com>

Alistair

> ---
>  hw/sd/pl181.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/hw/sd/pl181.c b/hw/sd/pl181.c
> index 649386ec3d..3fc2cdd71a 100644
> --- a/hw/sd/pl181.c
> +++ b/hw/sd/pl181.c
> @@ -173,7 +173,7 @@ static uint32_t pl181_fifo_pop(PL181State *s)
>      return value;
>  }
>
> -static void pl181_send_command(PL181State *s)
> +static void pl181_do_command(PL181State *s)
>  {
>      SDRequest request;
>      uint8_t response[16];
> @@ -402,7 +402,7 @@ static void pl181_write(void *opaque, hwaddr offset,
>                  qemu_log_mask(LOG_UNIMP,
>                                "pl181: Pending commands not implemented\n");
>              } else {
> -                pl181_send_command(s);
> +                pl181_do_command(s);
>                  pl181_fifo_run(s);
>              }
>              /* The command has completed one way or the other.  */
> --
> 2.21.3
>
>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]