[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-block] [PATCH v7 04/24] iotests: Rename filter_nbd to _filter_nbd

From: Max Reitz
Subject: [Qemu-block] [PATCH v7 04/24] iotests: Rename filter_nbd to _filter_nbd in 083
Date: Mon, 9 Nov 2015 23:39:13 +0100

In the patch after the next, this function is moved to common.filter.
Therefore, its name should be preceded by an underscore to signify its
global availability.

To keep the code motion patch clean, we cannot rename it in the same
patch, so we need to choose some order of renaming vs. motion. It is
better to keep a supposedly global function used by only a single test
in that test than to keep a supposedly local function in a common* file
and use it from a test, so we should rename the function before moving

Signed-off-by: Max Reitz <address@hidden>
 tests/qemu-iotests/083 | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tests/qemu-iotests/083 b/tests/qemu-iotests/083
index 1b2d3f1..664f0cf 100755
--- a/tests/qemu-iotests/083
+++ b/tests/qemu-iotests/083
@@ -49,7 +49,7 @@ wait_for_tcp_port() {
-filter_nbd() {
+_filter_nbd() {
        # nbd.c error messages contain function names and line numbers that are 
        # to change.  Message ordering depends on timing between send and 
        # callbacks sometimes, making them unreliable.
@@ -84,7 +84,7 @@ EOF
        $PYTHON nbd-fault-injector.py $extra_args "$port" 
"$TEST_DIR/nbd-fault-injector.conf" 2>&1 >/dev/null &
        wait_for_tcp_port "127\\.0\\.0\\.1:$port"
-       $QEMU_IO -c "read 0 512" "$nbd_url" 2>&1 | _filter_qemu_io | filter_nbd
+       $QEMU_IO -c "read 0 512" "$nbd_url" 2>&1 | _filter_qemu_io | _filter_nbd

reply via email to

[Prev in Thread] Current Thread [Next in Thread]