[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-block] [Qemu-devel] blkdebug event names [was: What to do abou
Re: [Qemu-block] [Qemu-devel] blkdebug event names [was: What to do about QAPI naming convention violations]
Tue, 17 Nov 2015 08:38:25 +0100
Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)
Eric Blake <address@hidden> writes:
> On 11/10/2015 07:35 AM, Markus Armbruster wrote:
>>>> Oddballs not related to case:
>>>> * enum BlkdebugEvent uses '.' in member names
>> I had a closer look at how the screwy names are used in QMP to see how
>> much of the mess is fixable within reason.
>> BlkdebugEvent is related to the external blkdebug interface described by
>> docs/blkdebug.txt. The two are actually decoupled, i.e. changing the
>> QAPI names doesn't affect the external debugging interface, and vice
>> versa. Making them different can only cause confusion, though. Not
>> sure we can fix the names.
> I think that having block/blkdebug.c:event_name duplicate qapi
> BlkdebugEvent is a mistake, and that we are better off unifying them.
> The other question is whether backwards compatibility is important here,
> or if we can just break the naming conventions to something sane. That
> is, if the primary user of blkdebug is our testsuite, and we fix our
> testsuite to match the new names, will we be breaking external users?
> Libvirt certainly doesn't expose blkdebug, and I doubt any other
> external wrapper will be that upset if we force better names here.
>> BlkdebugSetStateOptions and BlockdevDriver are input for blockdev-add.
>> Fixable. May not even need backward compatibility.
> Yep, I concur that blockdev-add is not stable yet, and that there are no
> other QMP uses of BlkdebugEvent, so unless anyone else complains, I
> think we can make the change to conventional spelling.
> At this point, I think 2.5 is too late, so the change will have to go
> into 2.6, but I'm preparing a patch for fixing this interface.
Definitely 2.6. Make sure to cc: Kevin (blkdebug maintainer).