[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [Qemu-devel] [PATCH v12 29/36] qobject: Rename qtype_co

From: Eric Blake
Subject: Re: [Qemu-block] [Qemu-devel] [PATCH v12 29/36] qobject: Rename qtype_code to QType
Date: Wed, 18 Nov 2015 16:27:14 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.3.0

On 11/18/2015 11:25 AM, Markus Armbruster wrote:
> Eric Blake <address@hidden> writes:
>> The name QType is more in line with our conventions for qapi
>> types, and matches the fact that each enum member has a prefix
>> of QTYPE_.
>> Signed-off-by: Eric Blake <address@hidden>
> At this point, the connection to QAPI is unobvious.
> You can either point to CODING_STYLE, which ask for type names in
> CamelCase, or to the next patch.

How about:

The name QType matches our CODING_STYLE conventions for type names in
CamelCase.  It also matches the fact that we are already naming all the
enum members with a prefix of QTYPE, not QTYPE_CODE.  And doing the
rename will also make it easier for the next patch to use QAPI for the
enum, which also wants CamelCase type names.

Feel free to touch up the commit message as you see fit.

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]