[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [PATCH 1/2] block: rename .bdrv_create() to .bdrv_co_cr

From: Kevin Wolf
Subject: Re: [Qemu-block] [PATCH 1/2] block: rename .bdrv_create() to .bdrv_co_create()
Date: Tue, 11 Jul 2017 11:46:34 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

Am 05.07.2017 um 12:22 hat Stefan Hajnoczi geschrieben:
> BlockDriver->bdrv_create() has been called from coroutine context since
> commit 5b7e1542cfa41a281af9629d31cef03704d976e6 ("block: make
> bdrv_create adopt coroutine").
> Make this explicit by renaming to .bdrv_co_create() and add the
> coroutine_fn annotation.  This makes it obvious to block driver authors
> that they may yield, use CoMutex, or other coroutine_fn APIs.
> Signed-off-by: Stefan Hajnoczi <address@hidden>

> diff --git a/block/file-win32.c b/block/file-win32.c
> index ef2910b..424f862 100644
> --- a/block/file-win32.c
> +++ b/block/file-win32.c
> @@ -544,7 +544,8 @@ static int64_t 
> raw_get_allocated_file_size(BlockDriverState *bs)
>      return st.st_size;
>  }
> -static int raw_create(const char *filename, QemuOpts *opts, Error **errp)
> +static int coroutine_fn raw_create(const char *filename, QemuOpts *opts,
> +                                   Error **errp)
>  {
>      int fd;
>      int64_t total_size = 0;

This isn't complete, we need a _co in the name like everywhere else.

/mnt/qemu/block/file-win32.c:594:5: error: unknown field 'bdrv_create' 
specified in initializer
     .bdrv_create        = raw_create,

There is also one more reference left to .bdrv_create in a comment
in block/block-backend.c, which you may want to update.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]