[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [PATCH 09/27] qdict: Introduce qdict_rename_keys()

From: Max Reitz
Subject: Re: [Qemu-block] [PATCH 09/27] qdict: Introduce qdict_rename_keys()
Date: Fri, 9 Feb 2018 19:19:25 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.2

On 2018-02-09 19:18, Max Reitz wrote:
> On 2018-02-08 20:23, Kevin Wolf wrote:
>> A few block drivers will need to rename .bdrv_create options for their
>> QAPIfication, so let's have a helper function for that.
>> Signed-off-by: Kevin Wolf <address@hidden>
>> ---
>>  include/qapi/qmp/qdict.h |  6 ++++++
>>  qobject/qdict.c          | 30 ++++++++++++++++++++++++++++++
>>  2 files changed, 36 insertions(+)
> Hmmm, looks OK, but I wonder whether this is going to be any more
> efficient than if we simply had a qdict_rename_key() function that you
> call multiple times.
> ("efficient" both in terms of code readability and runtime efficiency)
> So, I'll give you a
> Reviewed-by: Max Reitz <address@hidden>
> and let you decide.

Ah, I see, error handling is much easier this way, that's right.  OK,
R-b stands then.


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]