[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [PATCH v4 for 2.12 0/3] fix bitmaps migration through s

From: Vladimir Sementsov-Ogievskiy
Subject: Re: [Qemu-block] [PATCH v4 for 2.12 0/3] fix bitmaps migration through shared storage
Date: Tue, 27 Mar 2018 12:53:27 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0

27.03.2018 12:28, Vladimir Sementsov-Ogievskiy wrote:
26.03.2018 21:06, Max Reitz wrote:
On 2018-03-20 18:05, Vladimir Sementsov-Ogievskiy wrote:
Hi all.

This fixes bitmaps migration through shared storage. Look at 02 for

The bug introduced in 2.10 with the whole qcow2 bitmaps feature, so
qemu-stable in CC. However I doubt that someone really suffered from this.

Do we need dirty bitmaps at all in inactive case? - that was a question in v2. And, keeping in mind that we are going to use inactive mode not only for incoming migration, I'm not sure that answer is NO (but, it may be "NO" for
2.10, 2.11), so let's fix it in proposed here manner at least for 2.12.
For some reason, I can't get 169 to work now at all[1].  What's more,
whenever I run it, two (on current master, maybe more after this series)
"cat $TEST_DIR/mig_file" processes stay around.  That doesn't seem right.

However, this series doesn't seem to make it worse[2]...  So I'm keeping
it.  I suppose it's just some issue with the test.


[1] Sometimes there are migration even timeouts, sometimes just VM
launch timeouts (specifically when VM B is supposed to be re-launched
just after it has been shut down), and sometimes I get a dirty bitmap
hash mismatch.

[2] The whole timeline was:

- Apply this series, everything seems alright

(a couple of hours later)
- Test some other things, stumble over 169 once or so

- Focus on 169, fails a bit more often

- Can't get it to work at all

- Can't get it to work in any version, neither before nor after this patch

- Lose my sanity

- Write this email


hmm.. checked on current master (7b93d78a04aa24), tried a lot of times in a loop, works for me. How can I help?

O, loop finally finished, with:

169 6s ... [failed, exit status 1] - output mismatch (see 169.out.bad)
--- /work/src/qemu/master/tests/qemu-iotests/169.out    2018-03-16 21:01:19.536765587 +0300 +++ /work/src/qemu/master/tests/qemu-iotests/169.out.bad 2018-03-27 12:33:03.804800350 +0300
@@ -1,5 +1,20 @@
+ERROR: test__persistent__not_migbitmap__offline (__main__.TestDirtyBitmapMigration)
+methodcaller(name, ...) --> methodcaller object
+Traceback (most recent call last):
+  File "169", line 129, in do_test_migration
+    self.vm_b.event_wait("RESUME", timeout=10.0)
+  File "/work/src/qemu/master/tests/qemu-iotests/../../scripts/qemu.py", line 349, in event_wait
+    event = self._qmp.pull_event(wait=timeout)
+  File "/work/src/qemu/master/tests/qemu-iotests/../../scripts/qmp/qmp.py", line 216, in pull_event
+    self.__get_events(wait)
+  File "/work/src/qemu/master/tests/qemu-iotests/../../scripts/qmp/qmp.py", line 124, in __get_events
+    raise QMPTimeoutError("Timeout waiting for event")
+QMPTimeoutError: Timeout waiting for event
 Ran 8 tests

+FAILED (errors=1)
Failures: 169
Failed 1 of 1 tests

and I have a lot of opened pipes, like:

root       18685  0.0  0.0 107924   352 pts/0    S    12:19   0:00 cat /work/src/qemu/master/tests/qemu-iotests/scratch/mig_file


restart testing loop, it continues to pass 169 again and again...

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]