[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-block] [PATCH 13/18] xen: purge 'blk' and 'ioreq' from functio
Re: [Qemu-block] [PATCH 13/18] xen: purge 'blk' and 'ioreq' from function names in dataplane/xen-qdisk.c
Wed, 5 Dec 2018 17:28:54 +0000
> -----Original Message-----
> From: Anthony PERARD [mailto:address@hidden
> Sent: 04 December 2018 12:11
> To: Paul Durrant <address@hidden>
> Cc: address@hidden; address@hidden; xen-
> address@hidden; Stefano Stabellini <address@hidden>;
> Stefan Hajnoczi <address@hidden>; Kevin Wolf <address@hidden>; Max
> Reitz <address@hidden>
> Subject: Re: [PATCH 13/18] xen: purge 'blk' and 'ioreq' from function
> names in dataplane/xen-qdisk.c
> On Wed, Nov 21, 2018 at 03:12:06PM +0000, Paul Durrant wrote:
> > This is a purely cosmetic patch that purges remaining use of 'blk' and
> > 'ioreq' in local function names.
> > No functional change.
> > Signed-off-by: Paul Durrant <address@hidden>
> I don't think it's a good idee to use function names that could be use
> elsewhere, don't have a namespace. It makes it more difficult to figure
> out which function is called by just searching for the function name.
> Could you had a prefix?
> Maybe xendisk_ or xen_disk or xen_qdisk or xen_block or ..., so we can
> have xendisk_start_request, or xendisk_request_start. I don't have a
> preference beside staying away from generic names.
I'll add a xen_block_ prefix.
> Anthony PERARD