[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [PATCH v2 2/5] crypto/block: refactor qcrypto_block_*cr

From: Alberto Garcia
Subject: Re: [Qemu-block] [PATCH v2 2/5] crypto/block: refactor qcrypto_block_*crypt_helper functions
Date: Fri, 07 Dec 2018 13:37:55 +0100
User-agent: Notmuch/0.18.2 (http://notmuchmail.org) Emacs/24.4.1 (i586-pc-linux-gnu)

On Wed 05 Dec 2018 03:46:57 PM CET, Vladimir Sementsov-Ogievskiy wrote:
> qcrypto_block_encrypt_helper and qcrypto_block_decrypt_helper are
> almost identical, let's reduce code duplication and simplify further
> improvements.
> Signed-off-by: Vladimir Sementsov-Ogievskiy <address@hidden>

> +static int do_qcrypto_block_encrypt(QCryptoCipher *cipher,

I also prefer encdec (which is the naming already used in crypto/xts.c),
but I'm also fine with crypt.

Reviewed-by: Alberto Garcia <address@hidden>


reply via email to

[Prev in Thread] Current Thread [Next in Thread]