[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] migration/block: rename BLOCK_SIZE macro

From: Juan Quintela
Subject: Re: [PATCH] migration/block: rename BLOCK_SIZE macro
Date: Tue, 18 Feb 2020 13:47:20 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)

Stefan Hajnoczi <address@hidden> wrote:
> Both <linux/fs.h> and <sys/mount.h> define BLOCK_SIZE macros.  Avoiding
> using that name in block/migration.c.
> I noticed this when including <liburing.h> (Linux io_uring) from
> "block/aio.h" and compilation failed.  Although patches adding that
> include haven't been sent yet, it makes sense to rename the macro now in
> case someone else stumbles on it in the meantime.
> Signed-off-by: Stefan Hajnoczi <address@hidden>

Reviewed-by: Juan Quintela <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]