qemu-block
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH v6 00/15] hw/sd/sdcard: Fix CVE-2020-13253 & cleanups


From: Philippe Mathieu-Daudé
Subject: [PATCH v6 00/15] hw/sd/sdcard: Fix CVE-2020-13253 & cleanups
Date: Tue, 30 Jun 2020 12:03:27 +0200

Patches 5 & 6 fix CVE-2020-13253.
The rest are (accumulated) cleanups.

Since v5: Fix incorrect use of sd_addr_to_wpnum() in sd_reset()

Missing review:
[PATCH 01/15] MAINTAINERS: Cc qemu-block mailing list
[PATCH 03/15] hw/sd/sdcard: Move some definitions to use them
[PATCH 04/15] hw/sd/sdcard: Use the HWBLOCK_SIZE definition
[PATCH 05/15] hw/sd/sdcard: Do not switch to ReceivingData if
[PATCH 07/15] hw/sd/sdcard: Initialize constant values first
[PATCH 08/15] hw/sd/sdcard: Check address is in range
[PATCH 12/15] hw/sd/sdcard: Make iolen unsigned
[PATCH 13/15] hw/sd/sdcard: Correctly display the command name in

$ git backport-diff -u v5
Key:
[----] : patches are identical
[####] : number of functional differences between upstream/downstream patch
[down] : patch is downstream-only
The flags [FC] indicate (F)unctional and (C)ontextual differences, respectively

001/15:[----] [--] 'MAINTAINERS: Cc qemu-block mailing list'
002/15:[----] [--] 'hw/sd/sdcard: Update coding style to make checkpatch.pl 
happy'
003/15:[----] [--] 'hw/sd/sdcard: Move some definitions to use them earlier'
004/15:[----] [--] 'hw/sd/sdcard: Use the HWBLOCK_SIZE definition'
005/15:[----] [--] 'hw/sd/sdcard: Do not switch to ReceivingData if address is 
invalid'
006/15:[----] [--] 'hw/sd/sdcard: Restrict Class 6 commands to SCSD cards'
007/15:[----] [--] 'hw/sd/sdcard: Initialize constant values first'
008/15:[0004] [FC] 'hw/sd/sdcard: Check address is in range'
009/15:[----] [--] 'hw/sd/sdcard: Update the SDState documentation'
010/15:[----] [--] 'hw/sd/sdcard: Simplify cmd_valid_while_locked()'
011/15:[----] [--] 'hw/sd/sdcard: Constify sd_crc*()'s message argument'
012/15:[----] [--] 'hw/sd/sdcard: Make iolen unsigned'
013/15:[----] [--] 'hw/sd/sdcard: Correctly display the command name in trace 
events'
014/15:[----] [--] 'hw/sd/sdcard: Display offset in read/write_data() trace 
events'
015/15:[----] [--] 'hw/sd/sdcard: Simplify realize() a bit'

Philippe Mathieu-Daudé (15):
  MAINTAINERS: Cc qemu-block mailing list
  hw/sd/sdcard: Update coding style to make checkpatch.pl happy
  hw/sd/sdcard: Move some definitions to use them earlier
  hw/sd/sdcard: Use the HWBLOCK_SIZE definition
  hw/sd/sdcard: Do not switch to ReceivingData if address is invalid
  hw/sd/sdcard: Restrict Class 6 commands to SCSD cards
  hw/sd/sdcard: Initialize constant values first
  hw/sd/sdcard: Check address is in range
  hw/sd/sdcard: Update the SDState documentation
  hw/sd/sdcard: Simplify cmd_valid_while_locked()
  hw/sd/sdcard: Constify sd_crc*()'s message argument
  hw/sd/sdcard: Make iolen unsigned
  hw/sd/sdcard: Correctly display the command name in trace events
  hw/sd/sdcard: Display offset in read/write_data() trace events
  hw/sd/sdcard: Simplify realize() a bit

 hw/sd/sd.c         | 173 +++++++++++++++++++++++++++------------------
 MAINTAINERS        |   1 +
 hw/sd/trace-events |   4 +-
 3 files changed, 109 insertions(+), 69 deletions(-)

-- 
2.21.3




reply via email to

[Prev in Thread] Current Thread [Next in Thread]