qemu-block
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PULL 00/18] SD/MMC patches for 2021-02-20


From: Philippe Mathieu-Daudé
Subject: [PULL 00/18] SD/MMC patches for 2021-02-20
Date: Sat, 20 Feb 2021 01:12:51 +0100

The following changes since commit e90ef02389dc8b57eaea22b290244609d720a8bf:

  Merge remote-tracking branch 'remotes/armbru/tags/pull-qapi-2021-02-18' into 
staging (2021-02-19 17:22:42 +0000)

are available in the Git repository at:

  https://gitlab.com/philmd/qemu.git tags/sdmmc-20210220

for you to fetch changes up to 3e0a7693be30d6a6eda8a56f3862ac2e502a9e81:

  MAINTAINERS: Add Bin Meng as co-maintainer for SD/MMC cards (2021-02-20 
01:08:59 +0100)

----------------------------------------------------------------
SD/MMC patches

- Various improvements for SD cards in SPI mode (Bin Meng)
- Add Bin Meng as SD/MMC cards co-maintainer
----------------------------------------------------------------

Bin Meng (17):
  hw/sd: ssi-sd: Support multiple block read
  hw/sd: sd: Remove duplicated codes in single/multiple block read/write
  hw/sd: sd: Allow single/multiple block write for SPI mode
  hw/sd: Introduce receive_ready() callback
  hw/sd: ssi-sd: Support single block write
  hw/sd: ssi-sd: Support multiple block write
  hw/sd: ssi-sd: Fix SEND_IF_COND (CMD8) response
  hw/sd: ssi-sd: Fix STOP_TRANSMISSION (CMD12) response
  hw/sd: ssi-sd: Handle the rest commands with R1b response type
  hw/sd: sd: Fix address check in sd_erase()
  hw/sd: sd: Only SDSC cards support CMD28/29/30
  hw/sd: sd: Fix CMD30 response type
  hw/sd: sd: Move the sd_block_{read, write} and macros ahead
  hw/sd: sd: Skip write protect groups check in sd_erase() for high
    capacity cards
  hw/sd: sd: Skip write protect groups check in CMD24/25 for high
    capacity cards
  hw/sd: sd: Bypass the RCA check for CMD13 in SPI mode
  hw/sd: sdhci: Simplify updating s->prnsts in
    sdhci_sdma_transfer_multi_blocks()

Philippe Mathieu-Daudé (1):
  MAINTAINERS: Add Bin Meng as co-maintainer for SD/MMC cards

 include/hw/sd/sd.h |   2 +
 hw/sd/core.c       |  13 ++++
 hw/sd/sd.c         | 149 +++++++++++++++++++--------------------------
 hw/sd/sdhci.c      |   7 +--
 hw/sd/ssi-sd.c     | 136 +++++++++++++++++++++++++++++++++++------
 MAINTAINERS        |   1 +
 6 files changed, 199 insertions(+), 109 deletions(-)

-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]