qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 385f57: vfio: migration to trace points


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] 385f57: vfio: migration to trace points
Date: Tue, 23 Dec 2014 07:30:07 -0800

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 385f57cf9ad7566aa4fc125370f14902ea62aae5
      
https://github.com/qemu/qemu/commit/385f57cf9ad7566aa4fc125370f14902ea62aae5
  Author: Eric Auger <address@hidden>
  Date:   2014-12-19 (Fri, 19 Dec 2014)

  Changed paths:
    M hw/misc/vfio.c
    M trace-events

  Log Message:
  -----------
  vfio: migration to trace points

This patch removes all DPRINTF and replace them by trace points.
A few DPRINTF used in error cases were transformed into error_report.

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: c67676711c7202f48bc43d2f80125eaea355755e
      
https://github.com/qemu/qemu/commit/c67676711c7202f48bc43d2f80125eaea355755e
  Author: Frank Blaschka <address@hidden>
  Date:   2014-12-19 (Fri, 19 Dec 2014)

  Changed paths:
    M hw/misc/vfio.c

  Log Message:
  -----------
  vfio: fix adding memory listener to the right address space

Depending on the device, container->space->as contains the valid AddressSpace.
Using address_space_memory breaks devices sitting behind an iommu (and using
a separate address space).

Signed-off-by: Frank Blaschka <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: cf7087db10e2dc112e02782f1d1eb56ec42c728b
      
https://github.com/qemu/qemu/commit/cf7087db10e2dc112e02782f1d1eb56ec42c728b
  Author: Kim Phillips <address@hidden>
  Date:   2014-12-19 (Fri, 19 Dec 2014)

  Changed paths:
    M LICENSE
    M MAINTAINERS
    M hw/Makefile.objs
    M hw/misc/Makefile.objs
    R hw/misc/vfio.c
    M hw/ppc/spapr_pci_vfio.c
    A hw/vfio/Makefile.objs
    A hw/vfio/pci.c
    R include/hw/misc/vfio.h
    A include/hw/vfio/vfio.h

  Log Message:
  -----------
  vfio: move hw/misc/vfio.c to hw/vfio/pci.c Move vfio.h into include/hw/vfio

This is done in preparation for the addition of VFIO platform
device support.

Signed-off-by: Kim Phillips <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: 9ee27d7381c2d540ee976c7cbae941c66bb66e70
      
https://github.com/qemu/qemu/commit/9ee27d7381c2d540ee976c7cbae941c66bb66e70
  Author: Eric Auger <address@hidden>
  Date:   2014-12-19 (Fri, 19 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c

  Log Message:
  -----------
  hw/vfio/pci: Rename VFIODevice into VFIOPCIDevice

This prepares for the introduction of VFIOPlatformDevice

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: 079eb19cbb3079536788dfd58832824804815e48
      
https://github.com/qemu/qemu/commit/079eb19cbb3079536788dfd58832824804815e48
  Author: Eric Auger <address@hidden>
  Date:   2014-12-19 (Fri, 19 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c

  Log Message:
  -----------
  hw/vfio/pci: generalize mask/unmask to any IRQ index

To prepare for platform device introduction, rename vfio_mask_intx
and vfio_unmask_intx into vfio_mask_single_irqindex and respectively
unmask_single_irqindex. Also use a nex index parameter.

With that name and prototype the function will be usable for other
indexes than VFIO_PCI_INTX_IRQ_INDEX.

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: 5546a621a8801351601537b311539486b9b3ee79
      
https://github.com/qemu/qemu/commit/5546a621a8801351601537b311539486b9b3ee79
  Author: Eric Auger <address@hidden>
  Date:   2014-12-19 (Fri, 19 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c

  Log Message:
  -----------
  hw/vfio/pci: introduce minimalist VFIODevice with fd

Introduce a new base VFIODevice strcut that will be used by both PCI
and Platform VFIO device. Move VFIOPCIDevice fd field there. Obviously
other fields from VFIOPCIDevice will be moved there but this patch
file is introduced to ease the review.

Also vfio_mask_single_irqindex, vfio_unmask_single_irqindex,
vfio_disable_irqindex now take a VFIODevice handle as argument.

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: 462037c9e85b27149e71d7f5c7f41375ca6e47d5
      
https://github.com/qemu/qemu/commit/462037c9e85b27149e71d7f5c7f41375ca6e47d5
  Author: Eric Auger <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c

  Log Message:
  -----------
  hw/vfio/pci: add type, name and group fields in VFIODevice

Add 3 new fields in the VFIODevice struct. Type is set to
VFIO_DEVICE_TYPE_PCI. The type enum value will later be used
to discriminate between VFIO PCI and platform devices. The name is
set to domain:bus:slot:function. Currently used to test whether
the device already is attached to the group. Later on, the name
will be used to simplify all traces. The group is simply moved
from VFIOPCIDevice to VFIODevice.

Signed-off-by: Eric Auger <address@hidden>
[Fix g_strdup_printf() usage]
Signed-off-by: Alex Williamson <address@hidden>


  Commit: b47d8efa9f430c332bf96ce6eede169eb48422ad
      
https://github.com/qemu/qemu/commit/b47d8efa9f430c332bf96ce6eede169eb48422ad
  Author: Eric Auger <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c

  Log Message:
  -----------
  hw/vfio/pci: handle reset at VFIODevice

Since we can potentially have both PCI and platform devices in
the same VFIO group, this latter now owns a list of VFIODevices.
A unified reset handler, vfio_reset_handler, is registered, looping
through this VFIODevice list. 2 specialized operations are introduced
(vfio_compute_needs_reset and vfio_hot_reset_multi): they allow to
implement type specific behavior. also reset_works and needs_reset
VFIOPCIDevice fields are moved into VFIODevice.

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: a664477db8dac84cc046e9d79701eefda1d58703
      
https://github.com/qemu/qemu/commit/a664477db8dac84cc046e9d79701eefda1d58703
  Author: Eric Auger <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c
    M trace-events

  Log Message:
  -----------
  hw/vfio/pci: Introduce VFIORegion

This structure is going to be shared by VFIOPCIDevice and
VFIOPlatformDevice. VFIOBAR includes it.

vfio_eoi becomes an ops of VFIODevice specialized by parent device.
This makes possible to transform vfio_bar_write/read into generic
vfio_region_write/read that will be used by VFIOPlatformDevice too.

vfio_mmap_bar becomes vfio_map_region

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: d13dd2d7a957eacbb9e669c43dd9e19db969755b
      
https://github.com/qemu/qemu/commit/d13dd2d7a957eacbb9e669c43dd9e19db969755b
  Author: Eric Auger <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c
    M trace-events

  Log Message:
  -----------
  hw/vfio/pci: split vfio_get_device

vfio_get_device now takes a VFIODevice as argument. The function is split
into 2 parts: vfio_get_device which is generic and vfio_populate_device
which is bus specific.

3 new fields are introduced in VFIODevice to store dev_info.

vfio_put_base_device is created.

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: 62356b729281e7d6672193a98a072b1c7de04dd8
      
https://github.com/qemu/qemu/commit/62356b729281e7d6672193a98a072b1c7de04dd8
  Author: Eric Auger <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c

  Log Message:
  -----------
  hw/vfio/pci: rename group_list into vfio_group_list

better fit in the rest of the namespace

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: df92ee444884ba66b5cc95e3ff3d5579f89ed4aa
      
https://github.com/qemu/qemu/commit/df92ee444884ba66b5cc95e3ff3d5579f89ed4aa
  Author: Eric Auger <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/pci.c
    M trace-events

  Log Message:
  -----------
  hw/vfio/pci: use name field in format strings

Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: e2c7d025ada047a3f0225f89ff36626d1bd46e47
      
https://github.com/qemu/qemu/commit/e2c7d025ada047a3f0225f89ff36626d1bd46e47
  Author: Eric Auger <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/Makefile.objs
    A hw/vfio/common.c
    M hw/vfio/pci.c
    A include/hw/vfio/vfio-common.h
    M trace-events

  Log Message:
  -----------
  hw/vfio: create common module

A new common module is created. It implements all functions
that have no device specificity (PCI, Platform).

This patch only consists in move (no functional changes)

Signed-off-by: Kim Phillips <address@hidden>
Signed-off-by: Eric Auger <address@hidden>
Signed-off-by: Alex Williamson <address@hidden>


  Commit: dcbfc5cefb22e9219f8253dba87de33104ca73fe
      
https://github.com/qemu/qemu/commit/dcbfc5cefb22e9219f8253dba87de33104ca73fe
  Author: Alex Williamson <address@hidden>
  Date:   2014-12-22 (Mon, 22 Dec 2014)

  Changed paths:
    M hw/vfio/common.c
    M hw/vfio/pci.c

  Log Message:
  -----------
  vfio: Cleanup error_report()s

With the conversion to tracepoints, a couple previous DPRINTKs are
now quite a bit more visible and are really just informational.
Remove these and add a bit more description to another.

Signed-off-by: Alex Williamson <address@hidden>


  Commit: 03de06dde54df1f64bb099efe22edfa773b16e8e
      
https://github.com/qemu/qemu/commit/03de06dde54df1f64bb099efe22edfa773b16e8e
  Author: Peter Maydell <address@hidden>
  Date:   2014-12-23 (Tue, 23 Dec 2014)

  Changed paths:
    M LICENSE
    M MAINTAINERS
    M hw/Makefile.objs
    M hw/misc/Makefile.objs
    R hw/misc/vfio.c
    M hw/ppc/spapr_pci_vfio.c
    A hw/vfio/Makefile.objs
    A hw/vfio/common.c
    A hw/vfio/pci.c
    R include/hw/misc/vfio.h
    A include/hw/vfio/vfio-common.h
    A include/hw/vfio/vfio.h
    M trace-events

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/awilliam/tags/vfio-update-20141222.0' 
into staging

VFIO updates:
- Conversion to tracepoints (Eric Auger)
- Fix memory listener address space (Frank Blaschka)
- Move to hw/vfio/ and split common vs pci (Eric Auger & Kim Phillips)
- Trivial error_report() fixes (Alex Williamson)

In addition to enabling S390 with the address space fix and updating
to use tracepoints rather than compile time debug, this set of patches
moves hw/misc/vfio.c to hw/vfio/ and paves the way for vfio-platform
support by splitting common functionality from PCI specific code.

# gpg: Signature made Mon 22 Dec 2014 20:19:43 GMT using RSA key ID 3BB08B22
# gpg: Good signature from "Alex Williamson <address@hidden>"
# gpg:                 aka "Alex Williamson <address@hidden>"
# gpg:                 aka "Alex Williamson <address@hidden>"
# gpg:                 aka "Alex Williamson <address@hidden>"

* remotes/awilliam/tags/vfio-update-20141222.0:
  vfio: Cleanup error_report()s
  hw/vfio: create common module
  hw/vfio/pci: use name field in format strings
  hw/vfio/pci: rename group_list into vfio_group_list
  hw/vfio/pci: split vfio_get_device
  hw/vfio/pci: Introduce VFIORegion
  hw/vfio/pci: handle reset at VFIODevice
  hw/vfio/pci: add type, name and group fields in VFIODevice
  hw/vfio/pci: introduce minimalist VFIODevice with fd
  hw/vfio/pci: generalize mask/unmask to any IRQ index
  hw/vfio/pci: Rename VFIODevice into VFIOPCIDevice
  vfio: move hw/misc/vfio.c to hw/vfio/pci.c Move vfio.h into include/hw/vfio
  vfio: fix adding memory listener to the right address space
  vfio: migration to trace points

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/7e58e2ac7778...03de06dde54d

reply via email to

[Prev in Thread] Current Thread [Next in Thread]