qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 91288a: Add .dir-locals.el file to configure


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] 91288a: Add .dir-locals.el file to configure emacs coding ...
Date: Fri, 09 Oct 2015 04:30:04 -0700

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 91288a58a550be4dc80628456d5e1d2e91424827
      
https://github.com/qemu/qemu/commit/91288a58a550be4dc80628456d5e1d2e91424827
  Author: Daniel P. Berrange <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    A .dir-locals.el

  Log Message:
  -----------
  Add .dir-locals.el file to configure emacs coding style

Some default emacs setups indent by 2 spaces and uses tabs
which is counter to the QEMU coding style rules. Adding a
.dir-locals.el file in the top level of the GIT repo will
inform emacs about the QEMU coding style, and so assist
contributors in avoiding common style mistakes before
they submit patches.

Signed-off-by: Daniel P. Berrange <address@hidden>
Reviewed-by: Markus Armbruster <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: be9c5ddeabb73e9dee2d6922c03ffee4e1f4c8ec
      
https://github.com/qemu/qemu/commit/be9c5ddeabb73e9dee2d6922c03ffee4e1f4c8ec
  Author: Sai Pavan Boddu <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/sd/sdhci.c

  Log Message:
  -----------
  sdhci: use PRIx64 for uint64_t type

Fix compile time warnings, because of type mismatch for unsigned long
long type.

Signed-off-by: Sai Pavan Boddu <address@hidden>
Reviewed-by: Peter Crosthwaite <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 7af0fc994e85c0ff16eda6d7e328427b02a01008
      
https://github.com/qemu/qemu/commit/7af0fc994e85c0ff16eda6d7e328427b02a01008
  Author: Sai Pavan Boddu <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/sd/sdhci.c

  Log Message:
  -----------
  sdhci: Change debug prints to compile unconditionally

Conditional compilation hides few type mismatch warnings, fix it to
compile unconditionally.

Signed-off-by: Sai Pavan Boddu <address@hidden>
Suggested-by: Eric Blake <address@hidden>
Reviewed-by: Peter Crosthwaite <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: dc1442204a2235b1ad0c4bdceb3580c97f71f1b5
      
https://github.com/qemu/qemu/commit/dc1442204a2235b1ad0c4bdceb3580c97f71f1b5
  Author: Guenter Roeck <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/char/imx_serial.c

  Log Message:
  -----------
  imx_serial: Generate interrupt on tx empty if enabled

Generate an interrupt if the tx buffer is empty and the tx empty interrupt
is enabled. This fixes a problem seen when running a Linux image since
Linux commit 55c3cb1358e ("serial: imx: remove unneeded imx_transmit_buffer()
from imx_start_tx()"). Linux now waits for the tx empty interrupt before
starting to send data, causing transmit stalls until there is an interrupt
for another reason.

Signed-off-by: Guenter Roeck <address@hidden>
Reviewed-by: Peter Crosthwaite <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: eab2ac9d3c1675a58989000c2647aa33e440906a
      
https://github.com/qemu/qemu/commit/eab2ac9d3c1675a58989000c2647aa33e440906a
  Author: Paolo Bonzini <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M block/ssh.c

  Log Message:
  -----------
  block/ssh: remove dead code

The "err" label cannot be reached with qp != NULL.  Remove the free-ing
of qp and avoid future regressions by removing the initializer.

Signed-off-by: Paolo Bonzini <address@hidden>
ACKed-by: Richard W.M. Jones <address@hidden>
Reviewed-by: Fam Zheng <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 16033ba577059c5675e4c786234c46027380c29b
      
https://github.com/qemu/qemu/commit/16033ba577059c5675e4c786234c46027380c29b
  Author: Paolo Bonzini <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/i386/kvm/pci-assign.c

  Log Message:
  -----------
  pci-assign: do not include sys/io.h

This file does not exist on bionic libc and the functions it defines
are in fact not used by pci-assign.c.  Remove it.

Reported-by: Houcheng Lin <address@hidden>
Signed-off-by: Paolo Bonzini <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: ec5fd402645fd4f03d89dcd5840b0e8542549e82
      
https://github.com/qemu/qemu/commit/ec5fd402645fd4f03d89dcd5840b0e8542549e82
  Author: Paolo Bonzini <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/i386/pc.c

  Log Message:
  -----------
  pc: check for underflow in load_linux

If (setup_size+1)*512 is small enough, kernel_size -= setup_size can allocate
a huge amount of memory.  Avoid that.

Signed-off-by: Paolo Bonzini <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 4a7428c5a7e82f4dde3646e4a8cc8e54f3257e2a
      
https://github.com/qemu/qemu/commit/4a7428c5a7e82f4dde3646e4a8cc8e54f3257e2a
  Author: Christopher Covington <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M bsd-user/main.c
    M cpus.c
    M hw/intc/xics.c
    M hw/ppc/ppc.c
    M include/qemu/timer.h
    M linux-user/main.c
    M target-alpha/sys_helper.c

  Log Message:
  -----------
  s/cpu_get_real_ticks/cpu_get_host_ticks/

This should help clarify the purpose of the function that returns
the host system's CPU cycle count.

Signed-off-by: Christopher Covington <address@hidden>
Acked-by: Paolo Bonzini <address@hidden>
ppc portion
Acked-by: David Gibson <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 738c8b01ba4d020ee42c72e83a6aa3d9408a2530
      
https://github.com/qemu/qemu/commit/738c8b01ba4d020ee42c72e83a6aa3d9408a2530
  Author: Shraddha Barke <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M target-microblaze/op_helper.c

  Log Message:
  -----------
  target-microblaze: Remove unnecessary variable

Compress lines and remove the variable.

Signed-off-by: Shraddha Barke <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: f9b8e7f63acf9418238444aec654aba249a334ba
      
https://github.com/qemu/qemu/commit/f9b8e7f63acf9418238444aec654aba249a334ba
  Author: Shraddha Barke <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M target-ppc/kvm.c

  Log Message:
  -----------
  target-ppc: Remove unnecessary variable

Compress lines and remove the variable.

Signed-off-by: Shraddha Barke <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 885bdc95b165dc2b63bdc756be4919e948b9d27b
      
https://github.com/qemu/qemu/commit/885bdc95b165dc2b63bdc756be4919e948b9d27b
  Author: Stefan Weil <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M MAINTAINERS

  Log Message:
  -----------
  MAINTAINERS: Add NSIS file for W32, W64 hosts

The NSIS installer configuration is maintained by me.

Signed-off-by: Stefan Weil <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: f169f8fbca3999fe59f37a86822f305f7292949d
      
https://github.com/qemu/qemu/commit/f169f8fbca3999fe59f37a86822f305f7292949d
  Author: Marc-André Lureau <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M qapi/block.json

  Log Message:
  -----------
  qapi: add missing @

Signed-off-by: Marc-André Lureau <address@hidden>
Reviewed-by: Eric Blake <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: bf5f78efed26054c2ce71e6f4c30ece13bf06e87
      
https://github.com/qemu/qemu/commit/bf5f78efed26054c2ce71e6f4c30ece13bf06e87
  Author: Shraddha Barke <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/timer/m48t59.c

  Log Message:
  -----------
  hw: timer: Remove unnecessary variable

Compress lines and remove the variable.

Signed-off-by: Shraddha Barke <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 65cb2a14cacbc08c754f3cb41436fe6ece46593a
      
https://github.com/qemu/qemu/commit/65cb2a14cacbc08c754f3cb41436fe6ece46593a
  Author: Shraddha Barke <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/char/etraxfs_ser.c

  Log Message:
  -----------
  hw: char: Remove unnecessary variable

Compress lines and remove the variable.

Signed-off-by: Shraddha Barke <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: cb157af23833ca0762125f34b3fe73cfdbac297e
      
https://github.com/qemu/qemu/commit/cb157af23833ca0762125f34b3fe73cfdbac297e
  Author: David Gibson <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M .travis.yml

  Log Message:
  -----------
  .travis.yml: Run make check for all targets, not just some

ed173cb ".travis.yml: remove "make check" from main matrix" stopped running
make check for all the Travis build targets for various reasons.  It
continued to run make check on one Travis build, which builds for a big
list of all (? nearly all) our supported softmmu targets.

Unfortunately, due to a spacing / quoting error it only actually builds for
the alpha, arm, aarch64 and cris targets.  Specifically, the list of
targets is split over several lines.  Even with YAML folding, this will
leave spaces in the list, meaning $TARGETS won't have the value we need.

I had a look at the YAML spec and I couldn't quickly see a way of splitting
the list so that it doesn't end up with spaces, so this patch fixes the
problem by putting the whole list on one huge line.

Signed-off-by: David Gibson <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 778358d0a8f74a76488daea3c1b6fb327d8135b4
      
https://github.com/qemu/qemu/commit/778358d0a8f74a76488daea3c1b6fb327d8135b4
  Author: Markus Armbruster <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M hw/net/rocker/rocker.c
    M hw/net/rocker/rocker_desc.c
    M hw/net/rocker/rocker_fp.c
    M hw/net/rocker/rocker_of_dpa.c

  Log Message:
  -----------
  rocker: Use g_new() & friends where that makes obvious sense

g_new(T, n) is neater than g_malloc(sizeof(T) * n).  It's also safer,
for two reasons.  One, it catches multiplication overflowing size_t.
Two, it returns T * rather than void *, which lets the compiler catch
more type errors.

This commit only touches allocations with size arguments of the form
sizeof(T).  Same Coccinelle semantic patchas in commit b45c03f.

Signed-off-by: Markus Armbruster <address@hidden>
Acked-by: Jiri Pirko <address@hidden>
Reviewed-by: Eric Blake <address@hidden>
Reviewed-by: Jiri Pirko <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: c78d65e8a7d87badf46eda3a0b41330f5d239132
      
https://github.com/qemu/qemu/commit/c78d65e8a7d87badf46eda3a0b41330f5d239132
  Author: Markus Armbruster <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M linux-user/elfload.c
    M linux-user/main.c
    M linux-user/syscall.c

  Log Message:
  -----------
  linux-user: Use g_new() & friends where that makes obvious sense

g_new(T, n) is neater than g_malloc(sizeof(T) * n).  It's also safer,
for two reasons.  One, it catches multiplication overflowing size_t.
Two, it returns T * rather than void *, which lets the compiler catch
more type errors.

This commit only touches allocations with size arguments of the form
sizeof(T).  Same Coccinelle semantic patch as in commit b45c03f.

Signed-off-by: Markus Armbruster <address@hidden>
Reviewed-by: Eric Blake <address@hidden>
Reviewed-by: Stefan Weil <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: d1c002b6ae2dc81d97bbe23fe65e1960abdba9a4
      
https://github.com/qemu/qemu/commit/d1c002b6ae2dc81d97bbe23fe65e1960abdba9a4
  Author: Stefan Weil <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M linux-user/syscall.c

  Log Message:
  -----------
  linux-user: Remove type casts to union type

Casting to a union type is a gcc (and clang) extension. Other compilers
might not support it. This is not a problem today, but the type casts
can be removed easily. Smatch now no longer complains like before:

linux-user/syscall.c:3190:18: warning: cast to non-scalar
linux-user/syscall.c:7348:44: warning: cast to non-scalar

Cc: Riku Voipio <address@hidden>
Signed-off-by: Stefan Weil <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: deb847bfba7ee0ab8151842f5e9cb12d4daad3a3
      
https://github.com/qemu/qemu/commit/deb847bfba7ee0ab8151842f5e9cb12d4daad3a3
  Author: Dr. David Alan Gilbert <address@hidden>
  Date:   2015-10-08 (Thu, 08 Oct 2015)

  Changed paths:
    M tests/test-string-output-visitor.c

  Log Message:
  -----------
  tests: Unique test path for /string-visitor/output

Newer GLib's want unique test paths, and thus moan at dupes.
(Seen on Fedora 23 which has glib 2.46)

Uniquify the paths.

Signed-off-by: Dr. David Alan Gilbert <address@hidden>
Reviewed-by: Eric Blake <address@hidden>
Signed-off-by: Michael Tokarev <address@hidden>


  Commit: 8be6e623a28497d1dcd10547a573c9143ece525c
      
https://github.com/qemu/qemu/commit/8be6e623a28497d1dcd10547a573c9143ece525c
  Author: Peter Maydell <address@hidden>
  Date:   2015-10-09 (Fri, 09 Oct 2015)

  Changed paths:
    A .dir-locals.el
    M .travis.yml
    M MAINTAINERS
    M block/ssh.c
    M bsd-user/main.c
    M cpus.c
    M hw/char/etraxfs_ser.c
    M hw/char/imx_serial.c
    M hw/i386/kvm/pci-assign.c
    M hw/i386/pc.c
    M hw/intc/xics.c
    M hw/net/rocker/rocker.c
    M hw/net/rocker/rocker_desc.c
    M hw/net/rocker/rocker_fp.c
    M hw/net/rocker/rocker_of_dpa.c
    M hw/ppc/ppc.c
    M hw/sd/sdhci.c
    M hw/timer/m48t59.c
    M include/qemu/timer.h
    M linux-user/elfload.c
    M linux-user/main.c
    M linux-user/syscall.c
    M qapi/block.json
    M target-alpha/sys_helper.c
    M target-microblaze/op_helper.c
    M target-ppc/kvm.c
    M tests/test-string-output-visitor.c

  Log Message:
  -----------
  Merge remote-tracking branch 
'remotes/mjt/tags/pull-trivial-patches-2015-10-08' into staging

trivial patches for 2015-10-08

# gpg: Signature made Thu 08 Oct 2015 17:51:05 BST using RSA key ID A4C3D7DB
# gpg: Good signature from "Michael Tokarev <address@hidden>"
# gpg:                 aka "Michael Tokarev <address@hidden>"
# gpg:                 aka "Michael Tokarev <address@hidden>"

* remotes/mjt/tags/pull-trivial-patches-2015-10-08:
  tests: Unique test path for /string-visitor/output
  linux-user: Remove type casts to union type
  linux-user: Use g_new() & friends where that makes obvious sense
  rocker: Use g_new() & friends where that makes obvious sense
  .travis.yml: Run make check for all targets, not just some
  hw: char: Remove unnecessary variable
  hw: timer: Remove unnecessary variable
  qapi: add missing @
  MAINTAINERS: Add NSIS file for W32, W64 hosts
  target-ppc: Remove unnecessary variable
  target-microblaze: Remove unnecessary variable
  s/cpu_get_real_ticks/cpu_get_host_ticks/
  pc: check for underflow in load_linux
  pci-assign: do not include sys/io.h
  block/ssh: remove dead code
  imx_serial: Generate interrupt on tx empty if enabled
  sdhci: Change debug prints to compile unconditionally
  sdhci: use PRIx64 for uint64_t type
  Add .dir-locals.el file to configure emacs coding style

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/1d27b91723c2...8be6e623a284

reply via email to

[Prev in Thread] Current Thread [Next in Thread]