[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] more freezes with Knoppix

From: Kyle Hayes
Subject: [Qemu-devel] more freezes with Knoppix
Date: Wed, 4 Feb 2004 08:17:46 -0800
User-agent: KMail/1.5.4

I got QEMU from the Savannah CVS last night (i.e. about twelve hours ago) and 
built it from source.    I had a problem building qemu-fast, but was able to 
make that succeed (linking stage couldn't find libasound.so even though it 
was in the library path).  Everything else built fine.

When I boot Knoppix with the command line:

qemu -hda hda.img -cdrom ../knoppix/KNOPPIX_V3.3-2003-11-19-EN.iso -boot d -m 

(all on one line).  I've changed the amount of memory from my previous tests 
because I found that Knoppix is prone to crashes by itself with only 128MB of 
RAM.  I tested this on a 128MB laptop and found out the hard way :-)

I get a Linux command line prompt, but I cannot type anything in it.  When I 
boot off the hard disk image, I get the same thing.  QEMU is not using any 
CPU (or very little, around 1%), so I don't think that it is an infinite 
loop.  A signal will kill QEMU (I've tried HUP, INT and TERM and all worked).

Note that the boot prompt from LILO _does_ work.  It is only once I am in 
Linux that things do not work.  I can boot knoppix with the LILO prompt:

boot: knoppix lang=us tohd=/dev/hda1

That will install Knoppix on the disk image.  This seems to work.  When I 
mount the disk image with a loopback device afterward, it seems to be set up 
correctly.  However, booting it doesn't seem to work.

I am trying DeLi linux.  It has a nice small ISO image.  I am able to boot the 
ISO image and type on the command line once Linux boots.

Here's the command line I used to boot the ISO:

qemu -hda hda.img -cdrom deli-0.5.iso -boot d -m 256

Here's the command line I used to boot it once it was installed:

qemu -hda hda.img -m 256

It seems to work.  It doesn't install X by default apparently.   It runs a 2.2 
kernel, so this isn't something I'd want to use for a real server.  I have 
not been successful getting the network working, but I haven't tried too hard 
yet.  Any problems I'm having with the network are user error at this 
point :-)

So, Knoppix still gets confused by something, but DeLi seems to work.

Knoppix cannot figure out the VGA modes either.  It prompts for them right at 
boot time (off the CD, off the HD image, it doesn't).  So, I think the VGA 
BIOS isn't giving it information that it understands.  I've tried setting the 
vga=xxx parameter on the LILO boot prompt without success.

Knoppix tries both SVGA and VESA X servers without success.  Yet the 
autoprobing that happens at the beginning of the CDROM boot process finds a 
generic VESA card with 1024x768 resolution.  Perhaps the VGA BIOS isn't quite 
fully complete yet?

QEMU is amazing!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]