[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Qemu floppy emulation problems - partially solved

From: Johannes Martin
Subject: [Qemu-devel] Qemu floppy emulation problems - partially solved
Date: Tue, 17 Aug 2004 22:40:17 +0200 (CEST)


a little while ago we had some discussion about floppy emulation not
working in qemu once an OS has been installed. Our assumption was that
floppy access worked through int13 bios emulation but not really down at
the hardware level.

Today I noticed in Win98 that Windows would only offer to format a floppy
at 180kB. I then booted Win98 with a floppy inserted at boot time and
noticed two things:
- rather than two 'removable disk drives' Win98 now only reports one
  3 1/2" floppy drive (correctly)
- I can actually access that floppy and other floppies I insert later
  (no disk change problem as with CDs)

Observations on other OSes:
- Win95 reports a VFAT error and pretty much dies
- OS/2 can access the floppy that was inserted originally, as soon as I
  try to access any other floppy, qemu dies with a segmentation fault.

Tested on Debian/GNU Linux with a two week old qemu/CVS.

So I guess our initial assumption was at least partially incorrect, the
problem is not (primarily) the fdc hardware emulation in general but the
part OSes need to detect the kind of floppy drive installed. Apparently,
if no virtual floppy is inserted, the detection fails. I haven't actually
looked at the code yet - I imagine it to be quite easy to fix though.

Any hints how to find out why/where qemu segfaults under OS/2? How can I
get a core dump out of qemu? So far, my attempts to debug qemu using gdb
have failed miserably. :(


reply via email to

[Prev in Thread] Current Thread [Next in Thread]