[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Qemu floppy emulation problems - partially solved

From: Johannes Martin
Subject: Re: [Qemu-devel] Qemu floppy emulation problems - partially solved
Date: Tue, 17 Aug 2004 22:47:02 +0200 (CEST)


On Tue, 17 Aug 2004, Johannes Martin wrote:
> Today I noticed in Win98 that Windows would only offer to format a floppy
> at 180kB. I then booted Win98 with a floppy inserted at boot time and
> noticed two things:
> - rather than two 'removable disk drives' Win98 now only reports one
>   3 1/2" floppy drive (correctly)
> - I can actually access that floppy and other floppies I insert later
>   (no disk change problem as with CDs)

when I 'eject fda' in the Win98 guest, and try to access the floppy, I
receive hundreds/thousands of
        dma: DMA transfer is not read
and the guest pretty much stalls. 'change fda /dev/zero' gets things
straight again.

Actually, when I start qemu with -fda /dev/zero, the floppy drive is
detected ok. So that would be a very quick fix to the problem.

The only remaining problem is that I get a segfault when I try to format
the virtual floppy when it points to /dev/zero (I would expect a 'disk is
write protected' error).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]